1

After my old hard drive crashed, I decided to install Ubuntu alongside Windows 8.1 on my new drive (Windows was installed first, both with USB). Upon configuring Ubuntu, I partitioned about 698-ish Gb to Ubuntu and 232-ishGb to Windows.

As of then, partitions looked like this:

/dev/sda1 | ntfs | System Reserved | 350Mb

/dev/sda2 | ntfs | n/a | 232.54Gb

which are for Windows, and

/dev/sda3 | extended | 698.63Gb

which is for Ubuntu.

Now sda3 has subcategories, sda5 through sda6. sda5 held 690.76Gb, and sda6, the linux-swap, held 7.87Gb. These are all formatted as ext4.

As of late I've wanted to repartition my drives to store 750Gb on Windows and 250Gb (or however much will actually fit after what the system needs is taken; it's a 1Tb drive) on Ubuntu. So, I booted up my laptop with the USB I installed Ubuntu on, selected "Try Ubuntu without installing" and opened up GParted to resize things.

I started by shrinking sda5 to 250.00Gb, which worked perfectly. Then I had 440.76Gb of unallocated space, which I shifted to the left to it'd be next to sda2 enabling to me to expand it, thus expand Windows. But since it was unallocated, I couldn't expand sda2 into it in GParted or Windows Disk Management; I assigned a spot as sda7, but it required to have 1Mb of unallocated free space before it, which I couldn't remove...Analyzing that Mb of free space tells me its minimum size is 1Mb, but its maximum is 0Mb, and I can't change any values.

And I still can't expand sda2. Now, things look like this:

/dev/sda1 | ntfs | 350Mb

/dev/sda2 | 232.54Gb

/dev/sda3 | extended | 698.63Gb

>unallocated | unallocated | 1Mb

>/dev/sda7 | ext4 | 440.76Gb

>/dev/sda5 | ext4 | 250Gb

>/dev/sda6 | linux-swap | 7.87Gb

...Can anyone tell me what's going on? And if/how I can enlarge sda2?

Thanks so much!

1

As far as I'm concern, you have shrunk sda5, not sda3, so the allocated space (before creating sda7) is still inside sda3, and after being created, sda7 is inside sda3.

I suggest you delete sda7, shrink sda3 from the left, then you can enlarge sda2.

  • Thank you! That's my problem though: I can't shrink sda3 because it's an "extended" file system that has sda5-7 in subcategories. I can't get any of its subs out of it either :( – Micah Jun 19 '16 at 6:15
  • You can delete sda7 and shrink sda3 with gparted, and then as rancho suggest, enlarge Windows partition sda2 with Windows' bundled tool: Disk Management. – PyGeek03 Jun 19 '16 at 6:17
  • And if either mine or rancho's answer helped you, you should flag that answer as accepted :) – PyGeek03 Jun 19 '16 at 6:26
  • Well, sda3 seems like it's a "folder" under which sda7, 5, and 6 are located. I can't do anything to it :( – Micah Jun 19 '16 at 6:42
  • Oh, I think I just got it by turning SwapOff in the linux-swap partition. I tried that earlier. Thank you for your help! :D – Micah Jun 19 '16 at 6:46
0

In gparted first reduce your sda 7 and then select the whole sda3 and reduce it.

Then go to Windows and expand sda2 to the newly created unallocated disk space

GOLDEN RULE: Never ever touch your windows partition with gparted. Always use disk management of windows.

  • Thanks! I can't seem to do anything to sda3 though, because of its "extended" file system. I can't do anything expect check its properties and manage flags. – Micah Jun 19 '16 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.