1

I'm running Ubuntu 16.04 and I am using the proprietary NVidia driver (version 367.27). I have two graphics cards (a pair of EVGA Titan X) and two 4K displays (both are Dell P2715Q). The displays are connected to two DVI ports on the "first" Titan X (first meaning either PCI slot 1:0:0 or closest to the CPU, they're both the same in this case).

I noticed some graphical tearing and tracked it down to mismatched refresh rates. xrandr shows that one display is using 30Hz and the other is using 60Hz.

When I attempt to configure through the NVidia X Server Settings application, I end up with a messed up X config (see below) - the second display doesn't get any image and apps are weird and stretched on the primary.

What steps can I take to get both monitors on the same refresh rate?

Will this require adding custom display and monitor sections, one for each monitor?

xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 367.18  (buildd@lgw01-52)  Thu May 19 23:33:33 UTC 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL P2715Q"
    HorizSync       31.0 - 140.0
    VertRefresh     29.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX TITAN X"
    BusID          "PCI:1:0:0"
EndSection

Section "Screen"

# Removed Option "metamodes" "DP-0: 3840x2160_60 +0+0, DP-2: 3840x2160_60 +3840+0"
# Removed Option "SLI" "On"
# Removed Option "metamodes" "DP-0: nvidia-auto-select +0+0, DP-2: nvidia-auto-select +3840+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "AUTO"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
2

I was able to solve this using something similar to the second example posted on the Arch Wiki for NVidia cards - TwinView.

Each monitor is plugged into a separate graphics card and I've enabled SLI Mosaic mode. I've also forced the refresh rates to 60 Hz for the moment, but may uncomment this and use a range to see if that works.

I created a new file in /usr/share/X11/xorg.conf.d named 99-custom.conf and it looks like:

Section "Device"
    Identifier     "Card A"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX TITAN X"
    BusID          "PCI:1:00:0"
EndSection

Section "Device"
    Identifier     "Card B"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX TITAN X"
    BusID          "PCI:2:00:0"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Left Monitor"
    VendorName     "Unknown"
    ModelName      "DELL P2715Q"
    HorizSync       31.0 - 140.0
    VertRefresh     60.0 - 60.0
    ## Original Vertical Refresh rate
    #VertRefresh     29.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Right Monitor"
    VendorName     "Unknown"
    ModelName      "DELL P2715Q"
    HorizSync       31.0 - 140.0
    VertRefresh     60.0 - 60.0
    ## Original Vertical Refresh rate
    #VertRefresh     29.0 - 75.0
    Option         "DPMS"
EndSection

Section "Screen"
    Identifier     "Left Screen"
    Device         "Card A"
    Monitor        "Left Monitor"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "SLI" "Mosaic"
    Option         "BaseMosaic" "True"
    Option         "metamodes" "GPU-0.DP-0: 3840x2160_60 +0+0, GPU-1.DP-0: 3840x2160_60 +3840+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Right Screen"
    Device         "Card A"
    Monitor        "Right Monitor"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "SLI" "Mosaic"
    Option         "BaseMosaic" "True"
    Option         "metamodes" "GPU-0.DP-0: 3840x2160_60 +0+0, GPU-1.DP-0: 3840x2160_60 +3840+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier     "Default"
    Screen 0       "Left Screen" 0 0
    Option         "Xinerama" "0"
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.