1

I am new to CTags, and I tried it out for the first time a while back. It worked fine in Kate, I was able to use the keyboard shortcuts to jump to function definitions.

Now I'm trying it out again on the same system. I've opened up a new project, I've run ctags and it's created the tags file in the project root directory. I've confirmed it works in vim and I can jump between definitions as expected.

When I open Kate, I add the tags file (/home/jeff/project/tags) to the index targets, and click Update Index but now when I try to goto definition, it's always:

No hits found

I've also tried updating the database, and it's created a session_db_ with today's date.

I also tried creating the .kateproject file as proposed by an answer to this question, which is something I didn't have to do last time it worked anyway.

1

Figured it out, instead of adding the tags file (/home/jeff/project/tags) to the target index, I was supposed to just add the directory that the tags file is in (/home/jeff/project/) - not the tags file itself.

After changing the target index to /home/jeff/project/ and updating the index, then I am easily able to hop to definitions like I expect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.