I use Ubuntu 11.10 with Gnome Shell and have an encrypted home folder. I enabled auto log-in through the system settings/users-admin menu, as I expected it didn't work (because of my encrypted home folder/user I suspect). But now I don't have privileges to mount my eksternal hard-drive, and I can no longer disable the auto log-in function, since the un-lock button in users-admin menu is grayed out. It seems like my users privileges has been degraded. Does any one have an solution to how I disable auto log-in and regain my privileges?

1 Answer 1


You don't have your full capabilities or the ability to access your encrypted files when you're automatically logged in, so try logging out and back in, and see if that gives you these abilities. If that lets you disable automatic login, then that's the fast way.

If that doesn't work, then boot from an Ubuntu live CD/DVD or USB flash drive, open a Nautilus (i.e., file browser) window, and click on the volume for the Ubuntu system installed on your hard drive (it's listed near the top of the left pane of any file browser window) to mount it. Then quit this original Nautilus window and press Alt+F2 and run gksu nautilus (this opens a file browser window as root, with unlimited abilities). In the file browser window created by doing that, find the volume you just mounted (you might have to manually browse to it inside /media), and inside it, go into the etc directory. Inside that, go into the lightdm directory. Make a backup copy of the file lightdm.conf and then edit the original file to remove the line that begins autologin-user=. Then reboot (using the power/gear icon > Shut Down at the upper-right corner of the desktop), remove the CD/DVD or USB flash drive, and boot into your installed system. Now you should see a login screen like you used to.

(In summary, boot a live system and back up and edit /etc/lightdm/lightdm.conf to remove the autologin-user= line.)

  • 1
    This worked! Thank you. I skipped the whole "Live CD"-thing and just used 'gksu nautilus' directly from my user. Everything is back to normal now.Why I in the first place was allowed to enable auto log-in on an encrypted account, that's a whole different question...
    – reav
    Commented Nov 13, 2011 at 17:25
  • It's interesting that you were able to run Nautilus as root, even though you were not able to use the GUI configuration utility to disable automatic login. I had not considered that possibility, and I'm still not sure what broke one and not the other. (I can think of plenty of things that could--for example, PolicyKit could be broken but not sudo, but I cannot think of what would have caused that in this situation.) In any case, I'm glad your problem is now solved. Commented Nov 13, 2011 at 17:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .