1

I don't know why, but I know it happening.

After realizing that both Fn+F1 and Super+S switches between workspaces, I used xev and found out that Ubuntu senses Fn+F1 as Super+S.

In other words, Fn+F1 is interpreted as the same keystroke.

Why is this, and how do I fix it?

Added Info

  • The Leopard shortcuts menu has neither Fn+F1 nor Super+S
  • When I bind a shortcut to Fn+F1, the workspace selection screen appears, and when I back out, I find it to be set to Super+S.

Update

Turns out that my computer's bios reset whether I needed to use the Fn key to activate special keys, and now after fixing it I need to press Fn+F1, which is shown on my keyboard to be the Search key.

0

Navigate to System Settings -> Keyboard -> Shortcuts.

It should look like this:

There should be options available to configure the shortcuts there. Look for the Super+S shortcut and change it to F1.

Also, remember to change the F1 shortcut to Super+S afterwards and that should sort out the problem.

  • Neither F1 nor Super+S shows on the leopard shortcuts, and when I bound F1 to a different, unrelated shortcut, it shows as Super+S, behaving exactly like xev. – Lawful Lazy Jun 18 '16 at 16:38
  • Hold Super and then check what F1 does. What do you want F1 to do? – COrNotToC Jun 18 '16 at 16:47
  • This website: help.ubuntu.com/community/KeyboardShortcuts says that Super+S lets you "zoom out, show workplace switcher". – COrNotToC Jun 18 '16 at 16:52
  • Yes, I am aware that Super+S lets me switch workspaces; what I'm trying to say is that F1 behaves just like Super+S, even being interpreted as the same keystroke. – Lawful Lazy Jun 18 '16 at 17:47

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.