13

When I open an image file in eog it displays the wrong color.
Here is a screenshot of the problem:

image

And here is a screenshot of the problem temporarily fixed:

image

by using

xprop -root -remove _ICC_PROFILE

What I wanted to know is there a permanent way of fixing the problem instead of fixing it every time I open eog.

It also happens with gthumb, but I fix it by unchecking the button "Apply the embedded color profile".

4
  • 2
    Search settings -> color management -. I suspect you have installed a wrong color profile for your monitor.
    – Rmano
    Jun 17, 2016 at 22:23
  • 2
    Kindly edit your question and post a screenshot of the system settings -> color window.
    – Parto
    Jun 28, 2016 at 13:59
  • Does this happen with all image files or only some?
    – bashBedlam
    Jun 29, 2016 at 17:50
  • Same issue here. EOG alter the colours. It display correctly in gimp. When I use colour picker on EOG, the colour comes out with the wrong values.
    – Gael
    Jun 1, 2022 at 0:52

3 Answers 3

2

I had the same problem. It occurs in the Ubuntu Image Viewer (Eye of Gnome - eog) and also in its fork Eye of Mate (eom). The xprop -root -remove _ICC_PROFILE code also solves temporary my problem, but it also returns after the computer is suspended or turned off.

Solution:

I solved it (in Ubuntu LTS 20.04.4) going to Settings -> Color and disabling the Laptop Screen option (maybe another option might appear to you, so I recommend try each and see if it solves the problem). Your printer colors profile might be here too, so make sure to let disabled only the option that solves your problem.

Warning: I don't know all the consequences of this change, but it's unlikely that something dangerous occurs (like you getting a black screen).

1

I don’t have enough information to know for sure but I think that your problem is in the color profile of the image itself. If that’s the case then I’m fairly sure that I have a solution.
If you have a recent distribution of Ubuntu, then you have ImageMagick. You can check for it by typing just the word “convert” into your terminal. If you get several screens of usage information then you have it. If not, you may want to look for it on the Software Center. Assuming that you have ImageMagick, open your terminal, navigate to the directory where you image file is and type:

Convert “filename” –colorspace RGB  “newfilename”

Where “filename” is the name of your image and “newfilename” is what you want to call the modified version. Now try opening “newfilename” in eog and let us know what happens.

0

There seems to be a problem with color management.

As far as the sample screenshot is concerned: it would be helpful to know whether the original file comes with a color profile included, maybe the creator intended that it looks that way. Or it's in a different color space than sRGB. If it is due to one of these things, then conversion to sRGB will do the job, but it will actually alter the colors of the image. This is the code I use to convert scanned images with ImageMagick to correct the scanner colors:

convert /path/to/inputfilename.tif -strip -profile /path/to/scannerprofile.icc -profile /path/to/sRGB.icc -strip /path/to/outputfilename.tif

It tells ImageMagick that the input file has the scanner profile's specifications and to convert it to sRGB. The strip command removes all metadata, so that the output file does not contain the sRGB profile (because sRGB is the usual assumption for files without a profile).

If the monitor is involved, then converting won't help. The image will still look somewhat different, either under- or oversaturated, depending on how much the monitor specifications are different from the file's colorspace. Not to mention a wrong monitor profile or software bugs...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .