5

How to remove clock from the top panel in gnome-shell? enter image description here

4 Answers 4

7

It is possible by creating an extension.

mkdir -p ~/.local/share/gnome-shell/extensions/Disable_Clock@ocelot
cd  ~/.local/share/gnome-shell/extensions/Disable_Clock@ocelot

Make a metadata.json file.

gedit metadata.json

Cut following code, and Paste into the editor ,and Save.

{"shell-version": ["3.2"], "uuid": "Disable_Clock@ocelot", "name": "Disable Clock", "description": "Disable Clock from the top of panel"}

Make an extension.js file.

gedit extension.js

Cut following code, and Paste into the editor ,and Save.

const St = imports.gi.St;
const Main = imports.ui.main;

function init(meta) {
}

function enable() {
    Main.panel._centerBox.remove_actor(Main.panel._dateMenu.actor);
}

function disable() {
    Main.panel._centerBox.add_actor(Main.panel._dateMenu.actor);
}

Restart gnome-shell and Turn on "Disable Clock" extension by gnome-tweak-tool

3
  • Great! Thank you! Really good way with a possibility to turn it back easily. [For anyone else who might use this: I had to run gedit lines with sudo!]
    – Laurynas
    Nov 14, 2011 at 15:23
  • Not working in 18.04
    – jonathan
    Mar 2, 2019 at 8:41
  • This worked for me in 18.04 - extensions.gnome.org/extension/1110/hide-clock
    – jonathan
    Mar 2, 2019 at 8:52
2

Hide the clock in your current session with this command:

dbus-send --session --type=method_call --dest=org.gnome.Shell /org/gnome/Shell org.gnome.Shell.Eval string:'Main.panel._dateMenu.actor.hide();'
1
  • doesn't work in the latest versions of Ubuntu
    – user5245
    Mar 26, 2017 at 23:11
1

Press Alt+Right click the clock, there should be an entry saying Remove from panel.

4
  • 2
    Using Alt key while Right clicking clock doesn't seem to to anything, it just opens calendar like a simple Left click. Am I doing something wrong?
    – Laurynas
    Nov 13, 2011 at 15:20
  • That works in fallback mode with compiz disabled Nov 13, 2011 at 15:39
  • Yes! Press the Alt first and right click on the clock and a popup will ask you for 'Remove' and 'Remove from panel' choose 'remove from panel and select 'Don't reload'. Try it again.
    – all4naija
    Nov 13, 2011 at 15:44
  • You actually need alt-super-right
    – Amanda
    Jun 25, 2012 at 17:21
0

At teminal type the following:

sudo apt-get remove indicator-datetime
2
  • Removed indicator-datetime, rebooted system, clock is still there
    – Laurynas
    Nov 13, 2011 at 14:52
  • @Laurynas seriously? I kinda want to remove the indicator now to see if your joking. The is really still there? Jan 3, 2013 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.