0

Okay so First of all I'm really not familiar with Ubuntu or Linux at all I was a Windows user all my life but I heard from everywhere that the best way to set up a reliable server is to do it with Linux (for example Ubuntu Server). So I searched for easy to use step-by-step tutorials on doing so, and I found those three promising posts and videos:

idroot.net - install Owncloud 8 on Ubuntu 14.04

tecchannel.de - Owncloud 8.2 unter Ubuntu Server 14.04 LTS installieren(german site)

YouTube video

In the end I was sticking to the last one.

So I ended up installing Ubuntu 14.04.4 on my Intel NUC (which has a 1TB HD inside)

This all went smoothly and I came to the command prompt part there I updated everything then installed Apache2 (which worked) installed PHP and its required modules (which also seemed to work) and then MySQL database. Then I downloaded and Installed Owncloud 9.0.2 (which is the latest version as of now and it also seemed to work) and then as the guy in the video showed I made some changes in some documents I honestly have no idea of. So right now I really cant get any further I usually really don't want to rely on other people helping me personally but this time I'm seriously stuck.

So right now I can connect to https://192.168.0.241 in my local network and get to the Owncloud setup Page but then I simply want to setup an account and then this error message occurs:

image

I also tried Google for a solution but I didn't find anything that would help me only one post which also had the exact same problem but with no solution.

So please if someone with knowledge could help me I'd be really REALLY thankful because this was so frustrating already it took me a solid 4 hours only getting that far.

  • 1
    What the message is saying is that Owncloud cannot access MySQL. It is a configuration issue not related to the OS in itself. I haven't gone through the videos, but look into how owncloud connects to the database and make sure you have the db user properly set. – Grasshopper Jun 17 '16 at 16:26
  • thanks for the answer but like I mentioned I'm a complete noob when it comes to using linux or Server related stuff the things I use my computer for are gaming and surfing the web for 99% of the time, so when you tell me to look how owncloud connects to database I have no Idea what you want I really lack the fundamental knowledge of servers and how they communicate etc. thats why I'm asking for a SPECIFIC answer... – Kyotai Jun 17 '16 at 16:31
  • Relax. Post the image using the 'Add image option' ? (Giving links to other site is not suggested) – ankit7540 Jun 18 '16 at 8:36
0

As previously mentioned, the user doesn't have proper privileges on this database. Maybe it would be easier for you to manage the database through phpMyAdmin:

sudo apt-get update
sudo apt-get install phpmyadmin

During the installation you have to select Apache2 by hiting space, tab and enter.

Then enable the php5-mcrypt extension:

sudo php5enmod mcrypt

And restart apache2:

sudo service apache2 restart

By now phpMyAdmin should be accessible on http://192.168.0.241/phpmyadmin Login using root credentials and change Kyotais permissions accordingly. There are useful screenshots about this on this page: https://serverfault.com/questions/565343/how-to-grant-and-revoke-rights-to-tables-using-phpmyadmin

0

This solution is for you specifically.

In the section where you have to add database details; you have to enter the db name, password and table which you have made.

If you have followed the video closely then then add owncloud to all three fields here and try.

enter image description here (So type in owncloud for three fields here.)

  • Wow I did try using owncloud as table and db-name but never as password it actually worked :D thank you so much – Kyotai Jun 18 '16 at 13:57
  • While setting up database you ran: GRANT ALL ON owncloud.* TO 'owncloud'@'localhost' IDENTIFIED BY 'owncloud'; here, the underlying syntax is GRANT ALL ON database-name.* TO 'username'@'localhost' IDENTIFIED BY 'database password'; . The username here is the specific database user not owncloud user. In your case the db user is owncloud. – ankit7540 Jun 18 '16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.