2

About 3 days ago my wife did an update using software updater on her Packard Bell dot-s notebook running Lubuntu 14.04. Since then the wifi doesn't work. The applet icon has a little x and the menu show everything greyed out, although enable networking is ticked, enable wifi is not. lspci -nn | grep Network shows up the correct network controller (Intel Corporation Centrino Wirless-N 1000), ifconfig shows only eth0 and lo. The /etc/network/interfaces file looks like:

auto lo
iface lo inet loopback

When I add the following to the file:

auto wlan0
iface wlan0 inet dhcp
auto eth0
iface eth0 inet dhcp

All it does is make the system wait at boot time with Waiting for network configuration... after which it explains it will wait another 60 seconds then boots without wifi connection.

After booting ifconfig shows lo and wlan0 although there is no inet addr: in wlan0. Upon entering sudo ifup wlan0 it comes up with ifup: interface wlan0 already configured. I don't know how to get this to work again. I have tried various sites with no luck.

Output for ps aux | grep -i network is:

mywife    2543  0.0  0.0   4684   840 pts/9    S+   19:44   0:00 grep --color=auto -i network

and output for dmesg | grep iwl is:

[   16.446434] iwlwifi 0000:02:00.0: irq 43 for MSI/MSI-X
[   16.539321] iwlwifi 0000:02:00.0: loaded firmware version 39.31.5.1 build 35138 op_mode iwldvm
[   16.856846] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   16.856857] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   16.856865] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   16.856874] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[   16.864095] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[   16.871420] iwlwifi 0000:02:00.0: RF_KILL bit toggled to disable radio.
[   17.104178] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   17.778569] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
[   21.016195] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[   21.024372] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[   21.061736] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[   21.069193] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3

The output of rfkill list is:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no

The output for the NetworkManager --no-daemon command is here

The output for the sudo iwlist wlan0 scanning is here

  • What is the result of: dmesg | grep iwl? – chili555 Jun 17 '16 at 18:39
  • @Sneetsher the only process is network but doesn't include NetworkManager. – Jacques MALAPRADE Jun 17 '16 at 18:42
  • @chili555 I included the output above. – Jacques MALAPRADE Jun 17 '16 at 18:48
  • @Sneetsher the menu is not greyed out after running NetworkManager --no-daemon. However after clicking on wireless I still can't get on the network. ping 8.8.8.8 show connect: Network is unreachable and applet icon still shows No network connection. ifconfig only shows lo. – Jacques MALAPRADE Jun 17 '16 at 19:23
  • 1
    @Sneetsher I managed to get it working before trying the hard enabled/disabled switch. When editing the /var/lib/NetworkManager/NetworkManager.state I set both NetworkingEnabled=false and WirelessEnabled=false and rebooted. It came up with Networking disabled. I changed them both to =true and rebooted. Now it works. – Jacques MALAPRADE Jun 17 '16 at 20:38
1

With @Sneetsher help I managed to get this working. By setting /var/lib/NetworkManager/NetworkManager.state file from:

NetworkingEnabled=true 
WirelessEnabled=true 
WWANEnabled=true 
WimaxEnabled=true

to

NetworkingEnabled=false
WirelessEnabled=false
WWANEnabled=true 
WimaxEnabled=true

then rebooting and then setting it back to the initial setting and rebooting it seems to work again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.