conky: can't load Xft font 'Ubuntu:size=8,weight:normal' is the error message which appears in the terminal.

use_xft yes is present in the Conky config file.

The Conky file can be found here


Conky 1.10 configuration file use a new syntax ! Usually, it can convert old file "on the fly" but it seems that the version of 16.04 have some issue.

I had the same problem as you since I updated my machine. After a lot research, it seems that you must convert your configuration file to the new format.

To help you, there is a script located in :


see here : Convert to new 1.10 syntax

You must install "lua5.2" first and then make the script executable (as root)

Then, from ~/.conky where your config file should be located :

/usr/share/doc/conky-all/convert.lua <your_conkyrc>

Pay attention :

  • the configuration file should be in the "old" format
  • the conversion script overwrite the old version ! Make a copy before if needed

Then, you will still have the problem with the font, but if you convert as explained by DK Bose, it should work (it worked for me)

{font Ubuntu:bold:size=7}

(no '=' after 'font')

Good luck


I poked around on this, and with my environment, I had some different issues.

I'm using Unity with Compiz. My Lua Rings weren't working, and neither were my fonts. My Lua Rings were just in the wrong directory.

I had changed the font to Ubuntu. However, the format was wrong as indicated in this thread. However, my format didn't match any of the ones listed here in previous comments.

I'm attaching a sample of some of my properly formatted text from the memory section of my Seamod that works with my environment:

${offset 90}${font Ubuntu:bold:size=10}${color5}MEM

So for me, I had to find and replace:

font Ubuntu:size=10,weight:normal


font Ubuntu:bold:size=10

Instead of



font = 'Ubuntu:normal:size=8'

This assumes you are using Conky version 1.10.


Just remove ",weight" part from font lines in conky config:

For example, replace

${color5}${font Ubuntu:size=8,weight:normal}TOP
${font Ubuntu:size=8,weight:normal}${color1}${top name 1}${alignr}${top cpu 1}%


${color5}${font Ubuntu:size=8:normal}TOP
${font Ubuntu:size=8:normal}${color1}${top name 1}${alignr}${top cpu 1}%

P.S. Tested on Lubuntu 16.04 (conky 1.10).

  • 1
    worked for me on Ubuntu 18.04! – Waylon Flinn May 15 '18 at 16:56
  • I did it in Linux Mint 19 (Tara) Mate and after reload conky, same error appear. Like my config haven't changed anything. – Marcelo Ágil Nov 5 '18 at 16:33

That might be https://github.com/brndnmtthws/conky/issues/778 - use "true" instead of "yes".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.