When I launch nautilus from terminal the following error is printed and nautilus doesn't open up.

(nautilus:25179): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed

(nautilus:25179): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
Could not register the application: Timeout was reached

(nautilus:25179): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed

(nautilus:25179): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nautilus:25179): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

What could be the problem??


3 Answers 3


This answer by cortopy in ask.fedoraproject.org, worked for me.

I've been experiencing a similar problem today, only I couldn't open nautilus at all. So I'm wondering if this is due to some recent update clash.

This isn't a likely solution, but at least it allows me to carry on as normal.

First thing to try is sudo nautilus in a terminal. If it works, then it may mean that there is something wrong with active nautilus processess for your current user.

To be able to restart nautilus properly, do the following:

  1. See what nautilus processes are running :
    ps aux | grep nautilus
  2. Kill all nautilus processes you see :
    sudo kill PIDNUMBER
  3. Restart nautilus :
    nautilus -q
  • 4
    Useful, but this is a workaround, but not a real answer...
    – Stefano
    Sep 27, 2016 at 14:31
  • It is an answer that fixed it.
    – GeneCode
    Dec 3, 2020 at 4:22

Please type in Terminal:

sudo killall nautilus && (nautilus &)

This has reported here: Nautilus does not start

  • 1
    really helping and more fine solution for me ) Aug 14, 2018 at 9:05
  • I also have to do this from time to time, whenever nautilus stops working. Aug 27, 2018 at 8:29
  • Right, this is temporarily fixes only
    – Benny
    Aug 27, 2018 at 16:20

For me it was the following: I could open nautilus with

sudo nautilus

So then I killed all nautilus processes:

ps aux | grep nautilus
sudo kill <PID>


nautilus -q

And got:

(nautilus:4918): GVFS-WARNING **: can't init metadata tree /home/user/.local/share/gvfs-metadata/home: open: Permission denied

So I checked permitions of each of these folders doing:

ls -la /home/user/ | grep .local
ls -la /home/user/.local/ | grep share
ls -la /home/user/.local/share/gvfs-metadata/ | grep home

And the folder home was owned by root so I did:

sudo chown -R user:user /home/user/.local/share/gvfs-metadata/home

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.