4

I want to stop monitor from going to sleep in ubuntu 16.04. I am using /etc/X11/xorg.conf file in Ubutnu 14.04, which has below lines written in it.

Section "ServerFlags" 
Option "BlankTime" "60" 
Option "StandbyTime" "0" 
Option "SuspendTime" "0" 
Option "OffTime" "0" 
EndSection

And it is working fine in Ubuntu 14.04 but not working in Ubuntu 16.04.

During research I have found that xorg.conf is removed in Ubuntu 16.04. I want to do the same in Ubuntu 16.04. if anybody has any idea about the same then please let me know.

Thanks.

5
  • During research I have found that when upgrading to Ubuntu 16.04 from a previous release, both the fglrx driver and the xorg.conf will be removed, so that the system is set to use either the amdgpu driver or the radeon driver (depending on the available hardware).
    – User2546
    Jun 17 '16 at 12:27
  • What about system settings -> brightness and lock ?
    – EdiD
    Jun 17 '16 at 15:57
  • Turn off screen after 5 minutes and lock screen after screen turn off.
    – User2546
    Jun 18 '16 at 6:35
  • Change turn screen off : never
    – EdiD
    Jun 18 '16 at 7:48
  • Thanks for your reply. I know this but I want a script or .conf file like solution so that when it can be done automatically instead of manual interaction.
    – User2546
    Jun 18 '16 at 8:16
19

You can use gsettings for enabling and disabling monitor from going to sleep:

  • Disable turning off screen

    gsettings set org.gnome.desktop.session idle-delay 0
    
  • Enable turning off screen with 5 min delay

    gsettings set org.gnome.desktop.session idle-delay 300
    
8
  • EdiD, Thanks for your reply. In my initial testing it is working in Ubuntu 16.04 as per the expectation. I will test it more and update the test result here.
    – User2546
    Jun 18 '16 at 12:02
  • Thanks for this. Any thoughts on burn-in prevention? Anything to shift around the pixels a bit - this is what Android Wear does to prevent burn-in. Jun 21 '16 at 11:26
  • @RoundSparrowhilltx from what I know pixel shifting is built-in algorithm in plasma and oled tvs and It can't be done from command line.
    – EdiD
    Jun 21 '16 at 12:14
  • @EdiD, I have tested "gsettings set org.gnome.desktop.session idle-delay 0" in Ubuntu 16.04 and it works when internet is available but it does not work when internet is not available. Could please suggest the shell script or some kind of configuration so that it can work when internet not available.
    – User2546
    Aug 29 '16 at 12:01
  • @User2546 I can't imagine how idle-delay can be related to Internet connection.
    – EdiD
    Aug 29 '16 at 16:10
0

IN latest ubuntu, run the command.

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.