0

I installed google-chrome-stable by following instructions from here. When I right click on the Chrome launcher icon, It doesn't show options like 'Open a new window' or 'Open icognito window. It just lists the windows I have already open and options to unlock from launcher & to quit it.
Here's my google-chrome.desktop from ~/.local/share/applications

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Name=Chrome - Google Chrome
Icon=google-chrome
Exec=/opt/google/chrome/chrome %U
StartupNotify=false
StartupWMClass=google-chrome
OnlyShowIn=Unity;
X-UnityGenerated=true

Please help me fix it.

Thanks in advance.

  • Did you previously have Chrome installed on the same system? – Jacob Vlijm Jun 17 '16 at 9:54
  • I had it installed in 14.04, that was working fine. This happened after I did a fresh install of 16.04. – Labhansh Agrawal Jun 17 '16 at 9:56
  • So no chance on outdated .desktop files in ~/.local/share/applications? – Jacob Vlijm Jun 17 '16 at 9:57
  • yes, I didn't restore anything from my previous install. – Labhansh Agrawal Jun 17 '16 at 9:59
  • Not sure what the link in your question is sourced by, but the .desktop file is a simplified one, and the file includes a few outdated/deprecated keywords, which are not (anymore) in the recent Chrome versions. The recent version is in the repositories. – Jacob Vlijm Jun 17 '16 at 10:09
1

Uninstall Google Chrome and reinstall it this way, open a terminal and execute these commands :

sudo apt purge google-chrome-stable  
sudo rm /etc/apt/sources.list.d/google.list
echo "deb http://dl.google.com/linux/chrome/deb/ stable main" | sudo tee /etc/apt/sources.list.d/google-chrome.list
wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-key add -
sudo apt update
sudo apt install google-chrome-stable  

Now everything should work as expected.

  • @cl-netbox Thank you, But it still doesn't work. – Labhansh Agrawal Jun 17 '16 at 10:42
1

I got it solved myself by copying the desktop file from /usr/share/applications to ~/.local/share/applications.
cp /usr/share/applications/google-chrome.desktop ~/.local/share/applications

  • Now I am a bit puzzled; when I asked you "So no chance on outdated .desktop files in ~/.local/share/applications", you mentioned that was not the case. If you copy the global one locally, it is quite impossible anything changes, unless you overwrite an existing local one. – Jacob Vlijm Jun 17 '16 at 11:38
  • I don't know how it happened. I did a fresh install of Ubuntu and then installed chrome, It had been happening since the moment chrome installed. – Labhansh Agrawal Jun 17 '16 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.