0

So i got Crouton xfce ubuntu linux on my USB (im on HP Chrome 14) but whenever i download a file from chromium/web browser in xfce it goes to my USB AND CHROMEBOOK this is a problem because i planning to download files that take up alot of space and my chromebook only has 16GB.

Different version in-case the upper one makes no sense

I have crouton on my usb ( im using a HP Chromebook 14) when i use the web browser that is called chromium the files i download go straight to my USB AND CHROMEBOOK downloads.

Edits: Edit i found out how in the settings and this was my location › media › removable › USB Drive › chroots › trusty › home › bamhamyt › Downloads BamhamYT is my linux name but when i download something it says Failed - Insufficient permissions

  • What do you mean by 'USB and Chromebook' ? You can change the location of the downloads to your required folder. – ankit7540 Jun 17 '16 at 1:41
  • How do change the location of the downloads? – BamhamYT Jun 17 '16 at 2:39
  • We need to more about your setup. Where does chroot run from ? USB or hard drive ? – ankit7540 Jun 17 '16 at 7:25
0

Its simple.

Open Chromium browser. So to address bar and type Chrome://settings and press enter. (or you can click the three small horizontal bars on the right top > Settings )

Scroll below and click Show advanced options. Scroll below and find the option to change the Downloads location. Change the download location to the required folder.

The user needs to have write access to the folder to save files.


Most Chromebooks have SD card slots. Hence, an SD card can be used as permanent additional storage device. (On my Chromebook the installed SD card protrudes out by only 2-3mm, HP chromebook 14). I use the card as my download folder for browsers.

  • i just tried and it did the same thing – BamhamYT Jun 17 '16 at 3:03
  • Then what happened ? – ankit7540 Jun 17 '16 at 3:04
  • i went in xfce i downloaded a 3mb file (star craft installation .exe file) and it went in my chromebook download place not the usb – BamhamYT Jun 17 '16 at 3:05
  • it doesn't even go in my usb crouton folder ( media › removable › USB Drive › chroots › trusty › home › bamhamyt › Downloads) – BamhamYT Jun 17 '16 at 3:07
  • i also tried going on xfce go on chromium and go to settings advanced and change the downloads to my usb and still didnt work – BamhamYT Jun 17 '16 at 3:15
0

Maybe you do not have the rights to modify the directory.

Write in terminal->

sudo chmod -R ugo+rw /media/removable/USB Drive/chroots/trusty/home/bamhamyt/Downloads

Now try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.