3

Couldn't come up with something better for the title.

But I'm trying to explain it better (and the GIF below explains it even better graphically). So, when I open Firefox on Lubuntu, no matter if it's from the Desktop shortcut (.desktop) or from the Terminal, instead of opening the Firefox right away in maximized it first goes half the screen height and THEN maximizes. So there's some sort of a lag.
Of course I've tried setting the width and height parameters, e.g. firefox -width 1280 -height 1024 and the "maximize" parameter firefox --window --maximize. None of those worked.

Since Lubuntu is meant for low performance hardware, I think hardware isn't an issue. I haven't seen this problem on Ubuntu and Linux Mint (yea, I know that these are a with bit different architecture than Lubuntu), which I've both used on this computer. I switched to Lubuntu, because it's more leightweight.

Here's a GIF to illustrate what behaviour is bugging me:
illustration

  • The gif isn't working. – fosslinux Jun 17 '16 at 0:44
  • It is. OP's point is valid! – DK Bose Jun 17 '16 at 0:53
  • OP, if you can, please snap your Firefox window to left half or right of your screen and then exit Firefox. When you restart Firefox, you should see Firefox open in the left half or right half of your screen instead of what it's doing now (upper half). Please edit your question to provide the additional info. – DK Bose Jun 17 '16 at 0:56
  • "you should see Firefox open in the left half or right half of your screen" >>> "you should see Firefox open transiently in the left half or right half of your screen inste" – DK Bose Jun 17 '16 at 1:14
  • This happens on my system too --> Ubuntu 16.04 LTS – Severus Tux Jun 17 '16 at 3:16
3

The solution for me is to go into about:config and turn the following to false from true:

layers.offmainthreadcomposition.async-animations

and

layers.offmainthreadcomposition.enabled

about:config

A couple of related links:

https://www.mozilla.org/en-US/firefox/40.0beta/releasenotes/ mentions "Improved scrolling, graphics, and video playback performance with off main thread compositing (GNU/Linux only)".

And the Arch wiki has more: https://wiki.archlinux.org/index.php/firefox_tweaks#Enable_OpenGL_Off-Main-Thread_Compositing_.28OMTC.29

|improve this answer|||||
  • 1
    wow! this works perfectly :-) . Thanks @DKBose – Severus Tux Jun 17 '16 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.