2

I unplugged my USB stick from Ubuntu 16.04 without the save remove option, but exfat should be fine doing so. No read write was happening, the partition does not use journaling. What I end up with is an unmountable USB stick with checksum error.

What tools are there to recover the partition table or at least the data on the USB stick? What I am doing now is scanning via parted. Has anyone experienced the same problem with exfat and recovery options? Unfortunately parted probably won't detect the partition because it does not support exfat.

I also tried to use Partition Wizard on Windows but it failed to detect anything, just showing unallocated space. How do I proceed? are there helpful tools under Windows or Ubuntu?

enter image description here

I also tried to use gpart -v /dev/sdb but it failed to detect anything. On OS X there is a tool called fsck_exfat, is there any on Windows?

update The disk is preinstalled with Parted Magic. After quick search no partition shows up.

  • Welcome to Ask Ubuntu! «are there helpful tools under windows or ubuntu?» Whether there are Windows tools or not is irrelevant/OT on this site. I will post an answer suggesting a procedure on Ubuntu. – Andrea Lazzarotto Jun 17 '16 at 11:21
2

exfat should be fine doing so. No read write was happening, the partition does not use journaling

The fact that the file system does not use journaling is the exact opposite of "being fine" removing a drive without unmounting it properly. ;) The OS can't easily fix inconsistencies because there is no such journal.

Use TestDisk

Briefly, your drive still has a partition table and the file system type shows up correctly as exFAT, as seen on your screenshot. Install TestDisk and run it on the device:

sudo apt install testdisk
sudo testdisk /dev/sdb

I have discussed this tool before here on AU, and you might also be interested in the TestDisk guide. As I wrote in this answer on the Unix & Linux Stack Exchange website:

The essential steps are:

  • scanning the drive
  • selecting the partition
  • pressing P to show the files
  • copying the deleted (red) files with C

In this case you might want to copy all files, not just the deleted ones.

0

Answer by OP

I followed the wiki

TestDisk 7.0, Data Recovery Utility, April 2015
Christophe GRENIER <grenier@cgsecurity.org>

Disk /dev/sdc - 124 GB / 115 GiB - CHS 15102 255 63
Partition               Start        End    Size in sectors
No partition found or selected for recovery


But this tool testdisk is without doubt most awesome. In the main menu I choose Advanced and proceeded, all files showed up and I copied them to the internal drive. Did I say this tool is awesome :).

Copying, please wait... 2 ok, 0 failed
Directory /media/sda
>drwxr-xr-x     0     0      4096 17-Jun-2016 15:13 .
 drwxr-xr-x     0     0       100 17-Jun-2016 15:13 ..
 drwx------     0     0     16384 17-Jun-2016 15:13 lost+found

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.