1

This question already has an answer here:

In an effort to get OpenGL working on a Dell XPS running 14.04 LTS on Intel graphics hardware, I followed some advice and did the following:

add-apt-repository ppa:oibaf/graphics-drivers
apt-get update
apt-get upgrade

Now OpenGL works! But the upgrade caused other video problems that make the computer practically unusable. For example, I can no longer run a terminal on the desktop; I can still get a text-mode terminal with ctrl-alt-F1 though.

How can I undo this upgrade? It's the last apt-thing I've done. Alternatively, how do I reinstall the original Dell driver?

More info: I'm pretty sure I'm a victim of this bug, which seems to be unresolved.

The following is info that the very helpful @edwinksl asked for. Too cumbersome for a comment.

jack@hitch:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.4 LTS
Release:        14.04
Codename:       trusty

jack@hitch:~$ glxinfo | grep -i version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.1.3
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 10.1.3
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.1.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0

marked as duplicate by Eric Carvalho, phoibos, Wild Man, Videonauth, user.dz Jun 18 '16 at 12:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers says: "To revert to standard Ubuntu drivers type the following in a prompt shell: $ sudo apt-get install ppa-purge $ sudo ppa-purge ppa:oibaf/graphics-drivers" – edwinksl Jun 17 '16 at 1:30
  • @edwinksl I'm asking how to uninstall a graphics driver, is that the same as removing a PPA? – I. J. Kennedy Jun 17 '16 at 1:41
  • 2
    The easiest way to remove a graphics driver you get from a PPA is to remove said PPA so that you don't have to worry about it updating your graphics driver again when you run sudo apt-get upgrade. One additional benefit of using ppa-purge is that it will install the graphics driver from the official repositories too so you don't have to do it yourself. There are other ways to achieve the same result using dpkg or synaptic but they are more involved. – edwinksl Jun 17 '16 at 1:43
  • @edwinksl I did your ppa-purge suggestion but the problem didn't go away. I'm certain that it was my graphics driver upgrade that caused this, but I'm not certain how to figure out if I'm running the old driver or new, i.e. whether the purge worked or not. – I. J. Kennedy Jun 17 '16 at 23:26
  • Just to be clear, the ppa-purge suggestion also comes from the dev who packages the drivers that you used, not just from me. The PPA page also says "only 14.04 and 14.04.1 are supported" and "14.04.2 and later are not supported". Can you do lsb_release -a in your terminal and tell us what it says? After that, to check your OpenGL version, can you do sudo apt-get install glxinfo and then run glxinfo | grep -i version? – edwinksl Jun 17 '16 at 23:45
1

It turns out that when I did the apt-get upgrade, the install was not completely successful. Some packages were "held back" See this answer for more. Issuing another apt-get install on the held back packages fixed the problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.