2

I'm using Ubuntu 16.04 and can't print with my Brother HL-2240 printer. I went through all the steps of setting it up through the Printers/System Settings, and chose all the recommended drivers/locations, but it still doesn't work.

This is a picture of how everything is set up right now: enter image description here

Right now, I'll try to print something and then it disappears from the queue in seconds.

I tried downloading the driver from here as well: http://support.brother.com/g/b/downloadhowto.aspx?c=us&lang=en&prod=hl2240_us_eu&os=128&dlid=dlf006893_000&flang=4&type3=625

 Step1. Download the tool.(linux-brprinter-installer-*.*.*-*.gz)

The tool will be downloaded into the default "Download" directory.
(The directory location varies depending on your Linux distribution.)
e.g. /home/(LoginName)/Download

Step2. Open a terminal window and go to the directory you downloaded the file to in the last step.

Step3. Enter this command to extract the downloaded file:

Command: gunzip linux-brprinter-installer-*.*.*-*.gz

Step4. Get superuser authorization with the "su" command or "sudo su" command.

Step5. Run the tool:

Command: bash linux-brprinter-installer-*.*.*-* Brother machine name

Step6. The driver installation will start. Follow the installation screen directions.


 When you see the message "Will you specify the DeviceURI ?",

 For USB Users: Choose N(No)
 For Network Users: Choose Y(Yes) and DeviceURI.

The install process may take some time. Please wait until it is complete.

But I can't figure out how to do step 5 which is: Command: bash linux-brprinter-installer-..- Brother machine name

I'm not sure what machine name is supposed to be. I tried HL-2240, HL2240, HL 2240, and 2240 without result.

  • Please try to explain exactly what Step 5 is, or where you're having trouble. People arent going to click links to find the instructions you were trying to use, it's best to include here, so people don't have to search for how to help you. – user508889 Jun 16 '16 at 23:41
  • I have that same printer. Try this driver instead: Brother HL-2040 Foomatic/hl1250 (recommended) It works, but don't expect great print quality. – Alcuin Arundel Jun 17 '16 at 0:51
  • Thanks, Alcuin. You're right, it prints, but doesn't look that good. – boy Jun 17 '16 at 1:04
  • Try to download (Generic LPR printer driver - deb package 3.1.0-1 and Generic CUPSwrapper printer driver deb package 3.1.0-1) and install with gdebi. – kyodake Jun 17 '16 at 1:05
2

So I got it to work by downloading all the following drivers: LPR printer driver (deb package) CUPSwrapper printer driver (deb package) Generic LPR printer driver (deb package) Generic CUPSwrapper printer driver (deb package)

Then under Printer Properties my Make and Model is: Brother HL2240 for CUPS

I have no idea which driver's worked, I just threw everything against the wall and hoped something sticked. And now it works.

0

When adding the printer(Brother HL-2240D) I selected Brother HL-2142 and selected the recommended driver for that printer, and my Brother HL-2240D works perfectly. In my case the actual printer is on a Windows XP PC and thus I was adding a Network printer to Ubuntu.

0

Installed 16.04 then added Brother HL-2142 but just issued many blank pages on test. Downloaded HL-2240 Brother linux-brprinter-installer-..- and followed command line install. But had to use HL-2240DW model number at step 5 above and printer is now working correctly. I had similar problem with 14.04.

0

I did the following to make it work (USB HL2240D configuration)

  1. Download driver from this link

  2. Open a Terminal window and go to Downloads

  3. Type command: gunzip linux-brprinter-installer-2.1.1-1.gz

  4. Type command: sudo sh linux-brprinter-installer-2.1.1-1

    Input model name ->
    HL2240D
    -e 
    -e You are going to install following packages.
    -e    hl2240dlpr-2.1.1-1.i386.deb
    -e    cupswrapperHL2240D-2.0.4-2.i386.deb
    -e -n OK? [y/N] ->
    y
    -e 
    ............................
    ............................
    is License.
    =========================================
    -e 
    -e -n Do you agree? [Y/n] ->
    y
    ............................
    ............................
    -e -n Will you specify the Device URI? [Y/n] ->
    n
    -e 
    -e -n Test Print? [y/N] ->
    y
    -e 
    wait 5s.
    lpr -P HL2240D /usr/share/cups/data/testprint
    -e -n Hit Enter/Return key.
    

and then it was installed succesfully and works ok.

protected by Community Nov 13 '17 at 21:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.