2

I tried to solve this 'cause I'm not the only one with this problem, but still I can't get rid of it.

The problem is like in this gif:

enter image description here

BUT I saw that if I open nautilus using ALT+F2, it doesn't disappear. Why is that?

1
1

What is happening is that nautilus itself is always running in the background. If you start a new nautilus instance, it will just "attach" to the previously running instance of nautilus, then close itself. That is why it is disappearing from the launcher.

Try opening nautilus with Alt + F2 like you said, right click it, then hit "Lock to Launcher".

This should make it so that it won't disappear from the launcher, but it will also stay there the entire time.

You can also killall nautilus then try opening it from the launcher. Since there are no longer any more instances when you start it, it should stay open.

2
  • Is there a way to keep nautilus from "attaching" itself to the previous instance? The are many times when I would like to have more than one nautilus window open. – Eric Power Jun 16 '16 at 23:14
  • @EricPower It doesn't look like you can do this normally. If you have the window in the sidebar, you can right-click and select "Open a New Window" option. This will still attach it to the current nautilus daemon, but you can definitely have more than one window open at a time. Try opening nautilus more than once from the dash, it should create a new window every time. – Zzzach... Jun 17 '16 at 1:25
1

workaround in this post worked for me

I went to /usr/share/applications and took a backup of nautilus.desktop and org.gnome.Nautilus.desktop

Then:

  • In nautilus.desktop, removed "NotShowIn=Unity;"
  • In org.gnome.Nautilus.desktop, added "NotShowIn=Unity;" and removed "OnlyShowIn=Unity;"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.