6

Locking and unlocking will result in application windows being moved, sometimes to 'disabled' workspaces.

Setup:

  • 2 Monitors (HP 22cwa)
  • Workspaces disabled

Steps:

  1. Put application windows on 2 screens.
  2. Lock ubuntu.
  3. Take note of which screen has the login prompt (screen 1)
  4. Allow monitors to sleep.
  5. Move mouse, take note of which screen login prompt is on (sometimes screen 1, sometimes screen 2).
  6. Login.
  7. See all applications are still running (launcher).
  8. Realize some app windows are unavailable (using app switcher or launcher).
  9. Enable workspaces (all settings -> appearance, or use compizconfig tool).
  10. See 'missing' application window is on another workspace (that should have been disabled!)

That's pretty much all the steps. No idea how to fix this. If there is already a bug submitted, a link to that would be great. Just not having luck finding anything relevant.

  • 1
    Not a solution, but 16.10 does not have this bug. – Zach Mar 31 '17 at 16:29
1

This is not exactly a solution, but a work around to the problem: Go to Settings -> Brightness & Lock

Turn off 'Lock', and unselect 'Require my password when waking from suspend'

This will stop the screensaver lock screen from interfering with your desktop window layout in a multiple monitor situation.

Tested on Ubuntu 16.04

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.