5

Some time ago I upgraded to Windows 10 and wanted to give Ubuntu a try as well.

After the installation when I restarted my computer I have the options to choose from. When I choose Ubuntu everything is fine and after switching my computer off and on again I have this options again.

The problem occurs when I choose Windows boot manager. My windows 10 loads up I do my stuff etc.. When I switch it off and on again I do not have the options available to me and Windows 10 loads up automatically.

Also when I go to advanced system settings to set the default operating system to Ubuntu it is not on the drop down list, only Windows appears.

  • 1
    Try disabling "Fast startup" in windows - does that fix the problem ? – JonasCz Jun 16 '16 at 12:22
  • it did not work – mtrobert Jun 16 '16 at 13:11
  • maybe while it is off I should reinstall ubuntu?/ – mtrobert Jun 16 '16 at 13:11
5

You can try to get your GRUB back instead of going with third party tools like EasyBCD.

First Disable Fast startup on your windows. To do so :

On your windows 10,

open command prompt as administrator and execute powercfg /h off

Now, Go to Control panel --> Power Options --> Choose what power buttons do (its on Left side) --> "Change Settings that are currently unavailable"

and remove the tick mark on "Fast startup"

enter image description here

This disables fast start up on windows (Which is mandatory on dualboot).

Now reboot.

you should see your Grub. nice and clean.

NOTE :

If you have already tried EasyBCD you may have messed up your boot loaders. If so do this:

Go to your Multi-boot manager during startup ( On HP notebooks Keep pressing f9 as soon as you power on your machine, f12 on Dell notebooks ) and manually boot to Ubuntu.

OR

Restart after doing the above steps. Go to your BIOS.

Go to boot section and Under Boot loaders (Or similar) and bring the "Ubuntu on HDxxxx" option above Windows boot manager.

OR

Now reinstall grub by running the following commands :

sudo update-grub
sudo grub-install /dev/sda
sudo update-grub

Thats it.

  • Followed all the steps everything was fine until from grub menu I choose windows boot manager. I have a feeling that windows overwrites my current settings so I have to use windows. – mtrobert Jun 17 '16 at 8:21
0

Two methods- First: Try the software "EasyBCD" , it lets you choose the default OS.

Second: Another thing that you can do is press escape button when you switch on your machine, press escape before any logo appears, you shall see few options, select the one that says "boot device options" or something similar to that, that should give you the list of OS available.

P.s second one works just fine on my PC but I am not so sure about yours. Give it a try.

0

It could be a problem with windows hibernation. When windows 10 goes to shutdown it "helpfully" hibernates instead. to stop that behavior just hold-down shift while you press the shutdown button. If that doesnt work, try booting from the live cd and running boot-repair. to access it just run:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update && sudo apt-get install -y boot-repair && boot-repair

this will fix many grub2 problems.

source: ubuntu community support wiki, askubuntu.com

0

I too would recommend EasyBCD ( http://neosmart.net/EasyBCD/ ). It supports Windows 10 now. Just install it while you are in Windows 10, choose which all operating systems you need while start up ( it will auto recover 16.04 ) and use the boot menu provided by it.Let me know if you have any further issue.

  • Installed bcd and it said "due to some limitations set my microsoft(something to do with efi if I remeber it right) some of the features will not be able to use". – mtrobert Jun 16 '16 at 12:55
  • plus there is no ubuntu os in the drop down menu in bcd only windows 10 – mtrobert Jun 16 '16 at 12:56
  • also I am not able to add new entry for the os in bcd – mtrobert Jun 16 '16 at 12:59
  • You can use " add new entry " option as in this screenshot neosmart.net/EasyBCD/i/window.png – user227495 Jun 16 '16 at 18:33
  • @mtrobert , see this video : youtube.com/watch?v=8CHNVBfzZhQ – user227495 Jun 16 '16 at 18:39
0

This solution may be specific to my 2016 HP laptop.

You do need to turn off hybernate and fast start for other reasons - see fast boot explained but in my case, it still booted directly to Windows. I installed EasyBCD but was then informed that Linux is not an option because my machine is booting in UEFI mode - see Enable Legacy Boot Mode.

(Note: There is no need to reinstall windows or purchase fix software as suggested in some articles.)

In the BIOS menu, I simply enabled legacy support and disabled secure boot. This made the Startup menu available (via ESC) which allowed me to select ubuntu under boot device options.

If I want ubuntu I need to press ESC at startup, otherwise I suppose it reverts to UEFI and Windows.

0

In my HP laptop 2018, the problem is that Ubuntu is bootable but Windows 10 is going to sleep. I used boot-repair.

After that, press Esc while you are entering Windows 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.