When trying to upgrade, I get this error:

Not enough free disk space

The upgrade has aborted. The upgrade needs a total of 81.8 M free space on disk '/boot'. Please free at least an additional 81.8 M of disk space on '/boot'. Empty your trash and remove temporary packages of former installations using 'sudo apt-get clean'.

Then when I follow the instructions to free up space, I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  linux-image-3.13.0-53-generic* linux-image-3.13.0-63-generic*
  linux-image-3.13.0-64-generic* linux-image-3.13.0-65-generic*
  linux-image-extra-3.13.0-53-generic* linux-image-extra-3.13.0-63-generic*
  linux-image-extra-3.13.0-64-generic* linux-image-extra-3.13.0-65-generic*
0 upgraded, 0 newly installed, 9 to remove and 2 not upgraded.
8 not fully installed or removed.
After this operation, 929 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 180855 files and directories currently installed.)
Removing linux-image-extra-3.13.0-69-generic (3.13.0-69.112) ...
depmod: FATAL: could not load /boot/System.map-3.13.0-69-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-69-generic /boot/vmlinuz-3.13.0-69-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-69-generic /boot/vmlinuz-3.13.0-69-generic
Error! Your kernel headers for kernel 3.13.0-69-generic cannot be found.
Please install the linux-headers-3.13.0-69-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-69-generic /boot/vmlinuz-3.13.0-69-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-69-generic
grep: /boot/config-3.13.0-69-generic: No such file or directory
WARNING: missing /lib/modules/3.13.0-69-generic
Device driver support needs thus be built-in linux image!
depmod: ERROR: could not open directory /lib/modules/3.13.0-69-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
depmod: WARNING: could not open /tmp/mkinitramfs_1pM5O4/lib/modules/3.13.0-69-generic/modules.order: No such file or directory
depmod: WARNING: could not open /tmp/mkinitramfs_1pM5O4/lib/modules/3.13.0-69-generic/modules.builtin: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.13.0-69-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-3.13.0-69-generic (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:

I've followed many recommendation on how to fix this issue but it always returns the same error about the "no such directory"

Any help would greatly appreciated!

2 Answers 2


Perhaps you can try and free some space first by purging out old unwanted packages using:

sudo apt-get autoremove

..and then try again with the header install using:

sudo apt-get install linux-headers-$(uname -r)
  • It always gives the same error - tells me that it is going to remove linux-image-extra-3.13.0-69-generic but ends up with the same output as I originally posted.
    – SoarX
    Jun 16, 2016 at 9:55

try sudo apt-get install linux-headers-$(uname -r)

from: Error! Your kernel headers for kernel 3.5.0-25-generic cannot be found

  • That returns nearly the exact same message....thanks though
    – SoarX
    Jun 16, 2016 at 0:16
  • @SoarX Did this fix your problem?
    – fosslinux
    Jun 16, 2016 at 3:43
  • No, still exact same issue - some how I need to force the removal of linux-image-extra-3.13.0-69-generic or do it manually but I don't know how to do it....
    – SoarX
    Jun 16, 2016 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.