I have just installed xubuntu 16.04LTS on a Dell Inspiron Mini as a dual-boot with Windows 7.

When I booted it up for the first time yesterday, it worked fine. Today, however, I see the following:

/dev/sda5: recovering journal
/dev/sda5: clean, 174140/6045696 files, 1444115/24179712 blocks

I've consulted multiple other questions, such as Startup problem in 16.04 lts?, My Ubuntu is running fsck on every bootup, and Linux hanging at boot after fsck, which suggest that fsck is running on every boot or I have missing drivers, but none of them were exactly the same problem as I had.

However, in the problems concerning fsck, there is simply an irritating delay. Here it is stuck with this screen indefinitely, as far as I can tell. I've been waiting for quite a while now, and there hasn't been any change.

Do you have any possible solutions? Thanks.

  • If you have lights on your keyboard, do Caps Lock and Num Lock turn the lights on and off when it's hanging there? – anonymous2 Jun 15 '16 at 14:23
  • @anonymous2 There are no lights. – Jonathan Lam Jun 15 '16 at 14:24
  • Bother. :) If you press keys on the keyboard, does it enter anything on the screen? – anonymous2 Jun 15 '16 at 14:33
  • @anonymous2 No, it does not. Bother. – Jonathan Lam Jun 15 '16 at 14:36
  • Do you have a keyboard with lights you could plug in? – anonymous2 Jun 15 '16 at 19:07

Hold Right-Shift to access GRUB-bootloader. Go to advanced options and start recovery-mode. When recovery mode menu opens, select to continue normal boot. Now if you get to login open terminal and type sudo nano /etc/default/grub

This is what I did.

  1. I changed "splash quiet" part to "nomodeset radeon.modeset=0 systemd.recover_state=0" if I'm correct nomodeset deals with intel or nvidia cards, could work with ati too. I have old ati card so radeon.modeset=0 seemed right but I did not play with these more to be really sure.

  2. save file in nano by pressing ctrl+o and then exit ctrl+x

  3. back in terminal again run sudo update-grub

Now try to do normal reboot by sudo reboot and see if this got your system booting normally.

ps. So maybe the problem is with display drivers??

  • Like I said to the other answer, I can't edit files (read-only system) or log in. Therefore, I can't complete the steps you've provided. – Jonathan Lam Nov 10 '16 at 4:12
  • Read-only, huh? Sorry didn't notice that. Hope you find your way around this. – xSamle Nov 12 '16 at 9:54
  • Sorry. I didn't clarify in the question (I mentioned it in the comments below). – Jonathan Lam Nov 12 '16 at 14:51

I finally got mine to boot on Lubuntu (but I think I may end up using Xubuntu) after finding this solution on an archlinux forum.

Edit the kernel boot parameters, using (whichever text editor, I just used pico)

sudo pico /etc/default/grub

and where it says GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

add in systemd.restore_state=0 so it should read like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash systemd.restore_state=0"

My source is https://bbs.archlinux.org/viewtopic.php?id=201523&p=2

and also https://bugzilla.redhat.com/show_bug.cgi?id=1253523

where I found some documentation related to this about "backlight" on the archlinux wiki. I can't link it since I don't have enough rep :( can only link two URLs at best.

*Edit: Now I have enough rep maybe? So this is where I saw the information: https://bbs.archlinux.org/viewtopic.php?id=201523&p=2

and

https://bugzilla.redhat.com/show_bug.cgi?id=1253523

Hope this works for you, took me a month to figure it out!

Apparently long story short: At boot, the system is trying to control the keyboard backlight, but this laptop doesn't even have one. Thus, it's stuck checking a nonexistent boot up parameter of whether to start with the light on or off.

  • I cannot do this because the only way I can get to a text editor is via the "root terminal" option under "recovery mode", which had a read-only system. Do you know some method to get around this? Thanks. (Sorry for the late reply) – Jonathan Lam Aug 13 '16 at 3:59
  • I've done the following two things, one of which is permanent and one is temporary. Route 1) At the GRUB menu, press the key that lets you edit the boot command (for me, I think it was "c" or "e"). Then after the words quiet splash, enter the above systemd.restore_state=0 thing. My main reference is: wiki.ubuntu.com/Kernel/KernelBootParameters This is only a temporary fix for just booting. Hopefully you can actually boot and then (permanently) edit the boot parameters like above once you're logged in. – Aaron Chen Aug 14 '16 at 8:26
  • Route 2?) Is the one I'm not sure exactly how to do but it's something like this: You can boot into a Live CD/USB from "Try without installing" and from the terminal, change to the partition your (x)ubuntu is on. Then you can edit the boot parameters using the same commands. My half-reference is askubuntu.com/questions/266429/… just for how to access your partition. I'm really hand-waving with Route 2, and I'm not any IT professional or guru with Linux; maybe someone else can help. Else, I hope Route 1 works for you ~ – Aaron Chen Aug 14 '16 at 8:27

I had the same problem. Setting the kernel parameter loglevel=7 I found that the freeze is caused by the "Flush journal to persistent storage" operation that never ends. I resolved deleting the entire folder /var/log/journal. I believe that this is not the correct solution, but it is the onlyone that has worked for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.