1

This question already has an answer here:

I am currently using ubuntu 16.04 The weird thing is, I have installed google chrome in my laptop using ubuntu 14.04 and worked perfectly.

Somehow I just installed ubuntu 16.04 into my desktop and trying to install chrome but just wouldn't work.

I went to the google chrome website and clicked download, I have the 64bit deb file, clicked on it and my software GUI popped up. I click on install but it just keep on stalling, stays there forever and wouldn't move.

As I remember installing chrome in my laptop, after clicking install the process bar appears and bar will move but somehow now when I click install, it just keeps on showing install. I checked my launcher bar to the left, there's something new but only says waiting to install. It stays there for at least 2 hours and nothing happens.

Can someone give me a hand on what is going on? Thanks in advance.

marked as duplicate by Pilot6, Eric Carvalho, Community Jun 16 '16 at 1:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Yeah, it's a known bug. Should be fixed in later updates. For now, install deb files with the GDebi app – UniversallyUniqueID Jun 15 '16 at 10:12
  • The easiest way is to install a deb with sudo dpkg -i. If the dependencies are not installed, run sudo apt install -f after that. – Pilot6 Jun 15 '16 at 10:24
  • @BharadwajRaju is that bug for ubuntu 16.04? Because I just recently installed 16.04 into my pc but about 1-2mths ago I installed 14.04 into my laptop and my laptop installed chrome perfectly and I am new at ubuntu system so thought I did something wrong instead of having a bug – Dora Jun 15 '16 at 20:14
  • @Pilot6 thanks I took a look at the link, I believe that's what I need and will try that later when I get home. Thanks thanks – Dora Jun 15 '16 at 20:15
  • @BharadwajRaju just realized, this doesn't just happen to google though. I tried installing sublime text and same thing happened. – Dora Jun 16 '16 at 1:39
6

The fail-proof method of installing Chromium (open-source version of Chrome) would be to open a Terminal window and type:

sudo apt-get install chromium-browser  

Alternatively, installing Chrome from Terminal window is like this:

wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb  
sudo dpkg -i ./google-chrome*.deb  
sudo apt-get install -f
  • 1
    This is wrong. Did you ever try to run this command? – Pilot6 Jun 15 '16 at 10:22
  • 1
    @Pilot6: Sorry about that. My bad. I was thinking Chromium instead of Chrome. – ipse lute Jun 15 '16 at 10:25
  • 1
    This command will not install neither Chrome, nor Chromium. – Pilot6 Jun 15 '16 at 10:26
  • 1
    Now it looks much better. – Pilot6 Jun 15 '16 at 10:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.