49

I recently upgraded to ubuntu 16.04 and my SD card reader is not working. The system does not detect the reader at all. The output of lsusb is fairly uninformative:

lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 8087:07dc Intel Corp. 
Bus 002 Device 004: ID 0bda:572a Realtek Semiconductor Corp. 
Bus 002 Device 003: ID 046d:c245 Logitech, Inc. G400 Optical Mouse
Bus 002 Device 002: ID 04f3:024c Elan Microelectronics Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So I don't even know what sd card reader model I have. I'm using an ideapad u430.

Output of lspci:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)
09:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1)
12
  • Have you tried putting an SD card into the reader? With some memory card readers the connect via IDE or Sata inside your laptop and there is nothing to actually detect without the SD card being present. Jun 14, 2016 at 22:30
  • It could also be pci too, in which case "lspci" would be the command to find it. Jun 14, 2016 at 22:32
  • yes, I tried this with an sdcard in the reader, nothing changes :/ Jun 14, 2016 at 22:33
  • I just added the output of lspci Jun 14, 2016 at 22:35
  • Try to boot a completly different live Linux CD - i.e. Fedora, Manjaro or similar and check if the reader works there. Right know you dont know if is is a hard- or a software issue. If the reader works in another OS/Live CD its somehow clear it is a software-issue.
    – dufte
    Jun 17, 2016 at 12:35

3 Answers 3

86
+50

Probably an installation-issue which can be resolved with re-installation?! This would concern package udisks2.

  1. Reinstall package udisks2

    sudo apt-get install --reinstall udisks2
    
  2. Reboot the machine

    systemctl reboot
    

SD cards should be recognized then, after inserting them (in and out and in cautiously).

8
  • surprisingly this did work on Toshiba. On this laptop SD card worked in the previous ubuntu versions and stopped in 17.04.
    – culebrón
    Jul 25, 2017 at 13:00
  • Worked on Ubuntu 20.04 too. Thanks mate.
    – new2Ubuntu
    Mar 1, 2021 at 13:37
  • Sorry, didn't work for me on 20.04.
    – ffonz
    May 19, 2021 at 9:53
  • 1
    @ffonz - switch off WLAN - then reboot. May 21, 2021 at 9:30
  • @dschinn1001 I'll be d***d! It works! I have wifi always disabled since I work over lan. But I enabled wifi -> reboot: no improvement. Then disabled wifi again -> reboot. Then withdraw the SD-card and shoved it back in, and lo and behold... it worked! Thanks!
    – ffonz
    May 21, 2021 at 13:27
4

If you have installed a Card reader lsusb should give you something like:

Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
2

I am guessing you have Realtek card reader?

Download the Linux driver for your Realtek device for example rts5159 Open a new terminal session

Install the driver. Run the following commands:

cd where-your-driver-was-downloaded-extracted 
make
sudo make install
sudo depmod
1
  • 2
    It seems Realtek site removed all files related to drivers only two left of newer things. Mar 13, 2019 at 5:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.