6

Just started using Ubuntu 16.04 and for the first while everything was great. I could switch between my two graphic cards no problem. But after a regular update the graphics are being reported as Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)

I've tried following some answers on this site (for earlier versions of Ubuntu) about how to get rid of Gallium but to no avail.

Any help on this matter will be appreciated.

4

That would seem to indicate that you are now using the open source noveau drivers for your NVidia card. You need to go to the Additional Drivers tab under Software & Updates in System Settings, and select the proprietary NVidia drivers to use.

  • thanks for the response dobey. Under additional drivers in software & updates all drivers are open source none proprietary. My options are nvidia 361, 364, 358, 367, or x.org x server Nouveau diaplay driver – Student95 Jun 14 '16 at 20:40
  • NVidia 3xx are all proprietary drivers. Noveau is the open source driver. – dobey Jun 14 '16 at 21:40
  • 1
    Under additional drivers it says Im using NVidia 367 but the laptop is still using gallium. I also tried a few of the other drivers 364 etc but that didnt solve the issue – Student95 Jun 15 '16 at 20:41
2

I had the same problem with XPS13 ON INTEL HD 620 graphic card.

I tried several options, the only thing which worked was to upgrade kernel to 4.9. now the system uses the hardware gpu instead of cpu. You also might see the cpu usage will drop.

Here is the link to upgrade to 4.9 kernel version http://ubuntuhandbook.org/index.php/2016/12/install-linux-kernel-4-9-ubuntu-linux-mint/

  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Nov 15 '16 at 9:12
0

Having just spent several hours battling with the same problem, the solution (for me) was eventually straightforward. This was downloading the NVIDIA..384..run file directly from NVIDIA and installing it that way. Trying it through various package managers or apt-get was a dead-end. This was on an Alienware Area51 with a GTX1080Ti running Ubuntu 16.04 (with the problem caused by removing a 2nd 1080Ti card).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.