1

I just upgraded from 15.10 to 16.04. I had eclipse installed with the pydev environment. After the upgrade eclipse seemed to hang during first start. So after some time I killed the process. Second start went well but the pydev menu entires disappeared (new pydev project, preferences-pydev, etc). I removed pydev in eclipse, then re-installed eclipse from software-center and finally installed pydev again via eclipse "install new software". Eclipse shows pydev as installed but it is still not visible/usable.

Can anybody give me advice? My installed versions are: Ubuntu 16.04 LTS (amd64), Eclipse 3.8.1, PyDev for Eclipse 5.0.0.201605051159

  • After some research work I found out, that the pydev plugin has some unsatdisfied dependencies: 'com.python.pydev org.python.pydev org.eclipse.e4.ess.swt.theme – Anbey Jun 17 '16 at 15:08
  • (Again, I was too slow:) Further information: In my installation the pydev plugin has some unsatdisfied dependencies: 'com.python.pydev --> org.python.pydev --> org.eclipse.e4.ui.css.swt.theme, org.eclipse.e4.ui.services' The dependency from, .e4. modules seems suspicious to me, because ubuntu 16.04 brings the pretty old eclipse version 3.8.1. I installed the new "Mars" version from the eclipse download page in my home folder where the pydev plugin seems to work, but this version is unstable on my system (several hang-ups). So I have no solution yet. – Anbey Jun 17 '16 at 15:22
0

Pydev 4.5.5 works!

Finally I tried to install older versions of pydev via the links provided on http://www.pydev.org/update_sites/index.html

Here I used version 4.5.5, the highest version that doesn't require java 8. This works together with the eclipse 3.8.1.

Although I have installed openjdk 1.8 pydev doesn't seem to find a java 8 API. The possible reason is that the highest java version the osgi framework provides ist 1.7 ! The relvant configuration entry is (might be):

org.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSGi/Minimum-1.1,OSGi/Minimum-1.2,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5,JavaSE-1.6,JavaSE-1.7

Maybe this is the solution until Canonical provides an Eclipse with an updated osgi framework. To avoid the installation of inconpatible pydev 5.0 or higher during eclipse's software update function one should not use the standard pydev update site (http://pydev.org/updates).

0

Unfortunately, PyDev 5 does not work in Eclipse 3.8 anymore. See other user's report in pydev-perspective-not-showing-after-install-on-eclipse-3-8 - StackOverflow.

In the installation page of PyDev, the latest PyDev version to be used is listed below:

  • Eclipse 4.5, Java 8: PyDev 5.2.0
  • Eclipse 3.8, Java 7: PyDev 4.5.5
  • Eclipse 3.x, Java 6: PyDev 2.8.2
  • Python 2.5 or older: PyDev 5.5.0

My PyDev can work in Eclipse 3.8 by manually installing PyDev 4.5.5. It can be downloaded in PyDev for Eclipse - SourceForge.net.

After downloading the zip file, extract the contents of the zip file in the following folder and restart Eclipse.

     ~/.eclipse/org.eclipse.platform_3.8_155965261

If you do not have the folder, see the section Installing with the zip file in the installation page for hints.

I do not have Java 7 installed. My PyDev 4.5.5 can appear in Window->Preferences->PyDev in Eclipse 3.8 with Java 8.

-1

If I use the latest sources, eclipse will say "sources are not found". So I have to use https://dl.bintray.com/fabioz/pydev/4.5.5/ as the software source. It will work. My system is Ubuntu 16.04, 64 bits.

  • 1
    please a little explanation would be help based on your own experience with this same issue. – George Udosen Dec 12 '16 at 15:25
  • Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Dec 12 '16 at 15:43
  • will this better? – Roy Dec 13 '16 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.