I want to send files from my phone to my Laptop and vice versa through Bluetooth. But the Bluetooth on my system doesn't work. When I turn on the Bluetooth switch in System Settings > Bluetooth, nothing happens and also the visibility switch on the right hand side is always disabled.

Output of rfkill list is as follows:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

Output of dmesg | grep Blue is as follows:

[   29.519992] Bluetooth: Core ver 2.21
[   29.520012] Bluetooth: HCI device and connection manager initialized
[   29.520016] Bluetooth: HCI socket layer initialized
[   29.520019] Bluetooth: L2CAP socket layer initialized
[   29.520025] Bluetooth: SCO socket layer initialized
[   54.305795] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   54.305799] Bluetooth: BNEP filters: protocol multicast
[   54.305804] Bluetooth: BNEP socket layer initialized

I don't know if the drivers were installed or not and I don't know how to check it either.

Any idea what the issue is?


Update:

Output of lspci -knn | grep Net -A2; lsusb is as follows:

09:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290]
    DeviceName:  
    Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter [103c:18ec]
Bus 001 Device 003: ID 064e:c342 Suyin Corp. 
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • Please edit your question and add output of lspci -knn | grep Net -A2; lsusb terminal command. – Pilot6 Jun 14 '16 at 18:54
  • To check if bluetooth packages are installed, I suggest you to install Synaptic Package Manager and look for bluetooth on it. BTW we could file a bug report, as I'm suffering this too, in my case I have two bluetooth icons in the system panel, and making my PC visible from both doesn't makes it really visible. It also fails to find other bluetooth devices. – Nano Jun 15 '16 at 3:09
  • Search the bug reports for bluetooth RT3290 and you will find some. I really doubt it is fixed even now – Jeremy31 Jun 15 '16 at 22:02
  • @Jeremy31 You are right Jeremy. It seems it was an issue even with the older versions. – UrsinusTheStrong Jun 16 '16 at 14:51
  • 1
    I think some arch Linux users had it working up until kernel 4.0 – Jeremy31 Jun 16 '16 at 17:16

My ubuntu 16.04 couldn't find the Bluetooth devices, even though the devices's pairing switch was on.

Ubuntu 16.04 Bluetooth Speakers

In short, I tried following process.

  1. sudo nano /etc/bluetooth/main.conf
  2. Change #AutoEnable=false to AutoEnable=true (at the bottom of the file, by default)
  3. sudo service /etc/init.d/bluetooth restart

Then, my Ubuntu machine was able to find the Bluetooth devices!

  • 9
    apos thats not correct , it should be systemctl restart bluetooth.service – Amias Nov 1 '16 at 11:18
  • 1
    This worked for me with the change that @Amias mentioned. Thanks. – Erdnase Nov 6 '16 at 11:19
  • 4
    The best way is actually sudo service bluetooth restart – smac89 Feb 9 '17 at 3:29
  • working even if still not perfect, thx! I think there may have conflict with other bluetooth manager here.., this may help too askubuntu.com/a/680192/46437 – Aquarius Power Jun 7 '17 at 3:35
  • I am getting an error for the third command. Failed to restart etc-init.d-bluetooth.service.mount: Unit etc-init.d-bluetooth.service.mount not found. – monu suri Sep 8 at 5:11

I had the same problem. In my case I think it was a bug of my old installed version of unity control center, or some missing dependencies. Resolved easily updating unity-control-center:

sudo apt-get install unity-control-center

Hope it may help.

  • This one does it for me. Thanks – jaycode Sep 18 '17 at 13:32
  • Ah no, it only says "headphone connected" but no sound came out of it. – jaycode Sep 18 '17 at 13:36

My Bluetooth tended to "fall out", and I had to to do a reebot. But this solved it:

sudo service bluetooth restart

(easier than a reboot!)

  • 1
    Wouldn't this answer be a more permanent solution? Restarting the service every time while likely functional seems to me a less attractive choice. – Elder Geek Feb 16 '17 at 16:53

For me after two days of searching without any luck. I burned an image of Ubuntu on a USB stick, entered Try mode. Tested Bluetooth and it works and could find devices and pair.

Then I installed a new image of ubuntu on my HardDisk tried to install all of programs installed on old installation till that point when I found that Bluetooth stop working

I figured that I installed a tool called TLP for power management, When I removed it via apt remove tlp and reboot, Bluetooth worked and could find other devices!

Maybe TLP needs to be configured someway to work good with Bluetooth

I hope this may help you

Update:

I've installed the latest version of TLP and now Bluetooth working without any problems.

TLP releases on Gihub: here

Download the latest release uncompress

cd TLP-1.0
# use checkinstall so that you can remove it anytime
sudo checkinstall

Use PPA to get latest release

sudo add-apt-repository ppa:linrunner/tlp
sudo apt update
sudo apt install tlp

And reboot.

  • Your answer is inappropriate in several ways: 1. You don't know if TLP is installed (not default for most Ubuntu flavours). 2. Instead of uninstalling completely, use the solution from the FAQ. 3. Please don't suggest installing from source, use the PPA. 4. There is no difference between TLP 0.8 ... 1.0 with respect to your problem. I reckon checkinstall didn't work as expected and TLP is disfunctional now. Good luck with removing the wreckage --- Please edit your answer accordingly. – linrunner Jun 23 '17 at 10:25
  • This is brilliant, thanks so much! I completely forgot I installed TLP and it caused me a lot of issues. – Gerrit May 9 at 10:17

Note: this answer is for Debian only!

In my case the Bluetooth device was not detected. In my case it was part of the Qualcomm Atheros hardware:

$ lspci -knn | grep Net -A2
03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
        Subsystem: Hewlett-Packard Company QCA9565 / AR9565 Wireless Network Adapter [103c:217f]
        Kernel driver in use: ath9k
        Kernel modules: ath9k

Installing the proprietary/non-free firmware and rebooting helped.

sudo apt-get install aptitude
sudo aptitude install firmware-atheros
  • 1
    This is a Debian answer. There is no firmware-atheros package in Ubuntu. – Pilot6 Aug 26 '17 at 19:19
  • 1
    I got "Couldn't find any package whose name or description matched "firmware-atheros" " – Ferroao Aug 27 '17 at 15:09
  • Yes, sorry. I didn't realise that Ubuntu does not have that package. – wedesoft Aug 30 '17 at 8:43

After so many attempts to solve this issue the following commands did it for me.

rfkill block bluetooth

Then I do the following

rfkill unblock bluetooth

I always use this this to restart everything:

:~# rfkill block bluetooth; rfkill list; /etc/init.d/bluetooth restart;\
/etc/init.d/bluetooth status;\
modprobe -r btusb; modprobe btusb;\
/etc/init.d/bluetooth restart; /etc/init.d/bluetooth status
  • What do I do after that? Do I restart the computer? Also, I seem to be getting error messages from it: imgur.com/a/h5hO8 (the output scrolled past the window end, so I took two screenshots.) – Yaakov Ainspan May 2 '17 at 20:21

After some time with Bluetooth upload from phone not working on my laptop, I found that installing blueman-applet (sudo apt install blueman) and adding 'trust' for the device and then specifying to accept uploaded files fixed my problem. I don't really know why there are two Bluetooth icons in my taskbar now -- but the blueman-applet seems to provide a lot more options than the standard Gnome/Ubuntu applet.

The extra applet menu:

applet menu

Context menu of the Devices list allows 'trust' of device:

trust device

Local Services dialog allows Bluetooth to accept uploaded files:

accept files


EDIT: further digging shows that there is a 'Personal File Sharing' dialog recommended by Ubuntu that is supposed to support this functionality directly without blueman-applet. But it didn't work for me.

personal file sharing

Try this,

rfkill list 0: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: no 1: hp-bluetooth: Bluetooth Soft blocked: yes Hard blocked: no 2: phy0: Wireless LAN Soft blocked: no Hard blocked: no So from the list Bluetooth is blocked by rfkill, no wonder I cannot connect in the GUI. rfkill unblock bluetooth rfkill list 0: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: no 1: hp-bluetooth: Bluetooth Soft blocked: no Hard blocked: no 2: phy0: Wireless LAN Soft blocked: no Hard blocked: no 3: hci0: Bluetooth Soft blocked: yes Hard blocked: no After the unblock command I get a new device hci0 that is Soft blocked, but the hp-bluetooth device is unblocked and it doesn’t work from the GUI still.

hciconfig hci0 up Can't init device hci0: Operation not permitted (1) :$sudo hciconfig hci0 up [sudo] password for karibe: Can't init device hci0: Operation not possible due to RF-kill (132) rfkill unblock bluetooth hci0 rfkill list 0: hp-wifi: Wireless LAN Soft blocked: no Hard blocked: no 1: hp-bluetooth: Bluetooth Soft blocked: no Hard blocked: no 2: phy0: Wireless LAN Soft blocked: no Hard blocked: no 3: hci0: Bluetooth Soft blocked: no Hard blocked: no

After this everything is working as expected. I do not know why Rfkill is from time to time blocking bluetooth, but now I know how to unblock when I need to use it, and block when I don’t need to use it.

protected by Community Aug 6 '17 at 8:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.