7

This is a bit mysterious problem.

I upgraded Ubuntu 14.04 to 16.04. Now after each reboot the sound volume resets to 100%.

It is mysterious because it happens only on one computer, on another the sound volume is saved OK.

The other mystery is that I have Ubuntu 14.04 and 16.04 on the same computer with the common /home. On Ubuntu 14.04 the sound is aved OK, but on 16.04 it does not.

What can I do to troubleshoot this issue?

5 Answers 5

7

I created a new user and found that sound works correctly with the new user. That means that something was wrong in user configs. I found some configs and it looks like the problem is solved. The files were not in text format and I have no idea what that format is.

I removed all files from ~/.config/pulse/ and rebooted. Now it works OK.

I also removed all files from /root/.config/pulse/ to fix 100% volume on login screen.

I think they've changed format of some config files in the new version of pulseaudio. The config from 14.04 confused pulseaudio in some way.

I saw some bug reports about this issue. It may happen when you replace Ubuntu versions with the same /home.

Update: This looks like a distro upgrading bug. I upgraded 14.04 to 16.04 on another computer, and there was the same issue.

cookie file needs to be removed in ~/.config/pulse/ after an upgrade.

1

Disable the "Keep Settings" in the PulseAudio Equalizer.

1
  • This is the answer I was looking for!
    – mrek
    May 12, 2018 at 16:16
0

Inspired by the answer Pilot6 gave, I fixed mine by opening /home/dell/.config/pulse/default.pa in Gedit and doing a search for volume. It found it in 2 places and changing the second one that it found to the following set my startup volume to 63%.

Previous entry:

set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 65536

New entry:

set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 41288

Super-user privileges were not necessary, I just made the one simple change and restarted the machine and it worked fine. Just divide the 65536 by whatever percentage you want to set it to if you don't want 63%.

Hope this helps.

1
  • It is still broken. It should be saved as it was on system shutdown.
    – Pilot6
    Jul 4, 2016 at 14:27
0

To fix this problem open Terminal using (Ctrl+Alt+T) and type the below:

amixer -D pulse sset Master toggle

If you want to change it to a particular percentage type below replacing 50% for your desired volume:

amixer -D pulse sset Master 50%

Any problems, let me know. :)

9
  • Can you explain what this command does? And will the result stay after reboot? And sudo here looks wierd to me.
    – Pilot6
    Jun 14, 2016 at 17:37
  • The first command disables audio. The second sets Master volume to 50%.
    – Pilot6
    Jun 14, 2016 at 17:39
  • @Pilot6 -D is not disable, it's device. Jun 14, 2016 at 17:40
  • The first command should set the volume to whatever you toggle it to. The second command would set it to 50% or whatever volume you want by default. So the first command would be better if you don't want to set a default. Jun 14, 2016 at 17:45
  • 1
    sudo is wrong and it could be harmful in this case.
    – Pilot6
    Jun 14, 2016 at 17:49
0

So, for this problem-- the accepted solution is to mess with the pulse audio configs.

I was here in a desperate attempt to fix something in Raspbian.

A hack that would work for both is putting the amixer solution from @proprocrastinator in your ~/.profile configuration.

That way whenever you log in, ~/.profile runs, and

amixer -D pulse sset Master 50%

is executed as a result.

I had a problem with my microphone, fixed similarly with

amixer sset MIC 100%

for anyone else wandering in from the google for the same thing.

...I don't think this is the optimal solution. But, it probably will work if you can't find a better way to do it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.