I'd like to use Unity with Ubuntu 11.10, but everything from Unity runs really choppy and slow. I have an ATI graphics card and I have installed the drivers through "Additional Drivers". The drivers work, as I can play 3d games flawlessly. When I drag the mouse box around or drag windows around, it is really choppy. I previously had Ubuntu 10.10 and everything worked fine. I installed gnome 3 on 11.10 and it does the same thing Unity does, very choppy and slow graphics. However, if I choose Gnome Classic, everything is fine. I can drag the mouse box all around with no problems. I can drag windows around and it looks and feels great.

Is this a bug with Unity? Are others experiencing this? Or is there something I can do to fix this?

  • OK, first of all there is no Gnome Classic anymore in 11.10 that is Gnome shell fallback mode which leads to this, reinstall your drivers and get them from the amd site,and btw 11.10 comes with Gnome 3 already, again what you say you installed is called Gnome shell. – Uri Herrera Nov 13 '11 at 12:44
  • 1
    That is simply not true. Gnome Panel, which was used before Unity, has been ported to Gnome 3, and it is that application which is used as a fallback for Gnome Shell. This is because Gnome Shell currently depends on hardware support, which Gnome Panel does not. In other words, it's the same shell. – Jo-Erlend Schinstad Dec 29 '11 at 20:41
  • please mark one of the solutions as a courtesy. lifelike's solution worked for me and was very easy. – kobejohn Feb 27 '12 at 15:23
  • Have you solved this issue? – pl1nk Jun 24 '12 at 23:08

If you don't already have CompizConfig Settings Manager installed, get it from the Software Center.

Once you have it, go to OpenGL under General and uncheck 'Sync to VBlank'. That should solve it.

  • This worked very well for me. Thank you! I wonder if it has increased power consumption? Anyone know about that detail? – kobejohn Feb 27 '12 at 15:23
  • I can't speak for power consumption specifically, Ubuntu 11.04 and 11.10 have a known power regression issue. Fixable here: goo.gl/BYZ3G However, the VSync engine was running concurrently with ATI's graphic engine which is what causes the lag. – jonalmeida Mar 10 '12 at 3:27

my HP ProBook4250s has Intel® Ironlake Mobile x86/MMX/SSE2 installed with the OS reporting four processors and when running unity or gnome 3 is very slow and windows like in the way the resources are slow and do not respond unless I use the classic version.

I have had to remove the apache /mysql/ php5 stack I installed just to get the machine to run at a reasonable speed, this is a major pain in the proverbial as I need to develop using my laptop for its convenience.

I have also found that the dual screen set up does not get the right resolution until I unplug the second monitor and even then when I plug it in again it then becomes the primary monitor when it shows up and it should only be the secondary.

Also the secondary monitor is a touchscreen and when I plug it in and switch off the actual laptop monitor only then does the secondary monitor's touch screen calibrate properly. i assume its the Intel® Ironlake Mobile x86/MMX/SSE2 driver is missing however I cannot find one on the intel website


I've been having this issue with an NVidia card + binary drivers with 11.10 (I don't remember if the issue existed with 11.04). I finally found a workaround that appears to address the problem: restart the Compiz Window Decoration.

Open CompizConfig Settings Manager (you can install this using the software center - search for "CompizConfig Settings Manager"), Click "Window Management" on the left, and deselect "Window Decoration". Title bars will disappear after a number of seconds - don't freak out; re-select "Window Decoration" after everything has calmed down, and the lag will disappear.

For me the issue was that window dragging was never smooth, but over time a lag would develop whenever I attempted to move a window. Note that this workaround addresses the lag time, not the smoothness of the window dragging animation.

This possible explanation (not sure if it is applicable, since I think it refers to a bug report related to 2D Unity) suggests UnityFBO is getting bound unnecessarily, reducing framerates in apps.

This is the post that I found my workaround on.


Check out this link: ATI - Ubuntu Oneiric Installation Guide I think you need to remove your current driver and follow the steps in that link to install the latest ATI driver (which hapend to also be at version 11.10)

  • 1
    It says Gnome Classic at the login screen. Anyways, the graphics work fine with Ubuntu 2D and Gnome Classic, but not with Ubuntu or Gnome Shell. I've had to many problems with 11.10, and I don't feel like doing the stuff provided in that link, so I just went back to something that I know works well, 10.10 – Ingram Nov 14 '11 at 21:09
  • This is probably a driver issue. Unity 2D uses Metacity, the same window manager that Gnome Panel uses. It should be fast and responsive. It's not a problem with the shell itself. – Jo-Erlend Schinstad Dec 29 '11 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.