0

This question already has an answer here:

I've recently downloaded and installed Ubuntu on my lenovo ideapad 100, and once in a while it seems it is connected to the wi-fi, but the browser doesn't load any page; but, after turning off and on the "Enable Wi-Fi" option, it usually reconnects. Right now, it won't connect again and won't show any available wi-fi around. Any way to get the internet back without restarting the whole system?

marked as duplicate by Community Jun 14 '16 at 18:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I have a Lenovo G50-45 and I had the same issue. I fixed the problem by installing a third-Party driver and now the internet connects without issue. In order for me to find a resolution, please could you open terminal and run the command lshw and then add the results to this question? – proprocastinator Jun 13 '16 at 21:47
  • Which one did you install? I could try it and say if it worked for me too – Ilan Kaboom Jun 13 '16 at 21:52
  • It will most likely be a different wifi adaptor you have in your laptop, so it will be a different driver. If you do lshw in terminal though and then paste the results to your question I'm pretty sure either myself or someone else will be able to help you. :) – proprocastinator Jun 13 '16 at 21:54
  • which part should I add specifically? it's too long to paste all of the results – Ilan Kaboom Jun 14 '16 at 12:42
  • never mind, I got it: – Ilan Kaboom Jun 14 '16 at 12:45
0

Sure, are you using WPA or WEP encryption? You can use ifconfig to check if your adapter is being recognized; possibly something is causing it to be blocked or taken "down":

  1. sudo ifconfig

    if you see your wireless adapter there, then move on to step 2. If not, use

    sudo lshw
    

    to see if the adapter has been rfkilled or something else.

    1. If you're using WEP and your wireless adapter's name is "wlan0":

      sudo ifconfig wlan0 up
      sudo iwconfig wlan0 essid network_name key network_key
      sudo dhclient wlan0
      
    2. If you're using WPA and your wireless adapter's name is wlan0:

      sudo apt-get install wpasupplicant
      cd /etc
      sudo nano wpa_supplicant.conf
      

      And add:

      network={
          ssid="ssid_name"  
          psk="password"  
      }
      

    Then press Ctrl+x to save. Controls vary using vi, vim, etc. You could use a text editor, as well.

    sudo wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dwext
    sudo dhclient wlan0
    

*Some information gathered from this link:
How do I connect to a WPA wifi network using the command line?

Also try this if the above does not work:

ubuntu 14.04 wireless constantly disconnects

  • Much better, thanks @muru :D – P Smith Jun 13 '16 at 20:51
  • what should I put in /etc ? As you can see, I am very new to this, so which directory should it be? Or it doesn't matter? – Ilan Kaboom Jun 14 '16 at 12:41
  • Ok, I am such a noob. I got it and continued, and after doing wpa_spplicant -B ... -Dwext, it returned "Successfully initialized wpa_supplicant" but also "ioctl[SIOCSIWENCODEEXT]: Invalid argument" twice. I tried moving on to the dhclient but it got stuck and the net went out – Ilan Kaboom Jun 14 '16 at 12:59
  • Ok, it finished and I restarted, so far working great. Thank you, I'm a little embarrassed 😅 – Ilan Kaboom Jun 14 '16 at 13:06
  • Ok, it didn't work, once again the wi-fi stopped working but seems connected – Ilan Kaboom Jun 14 '16 at 13:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.