0

My desktop has an old mouse that has broken left and right click buttons that always double-click. I tried to solve that by enabling Mousekeys from the Accessibility settings, but there are a number of problems with this:

  1. I believe mousekeys is supposed to toggle when the Num Lock key is pressed, but it does not do so. Whether or not Num Lock is on, the mousekeys remains working; I can't use the numpad to type in numbers.
  2. At startup, even though the system settings says Mousekeys is still enabled, it actually isn't. The numpad doesn't start working in Mousekeys mode until I toggle the MouseKeys option off and on again.
  3. The motion of the mouse using the keys is far too slow to be usable. It seems to travel at less than 10 pixels per second.

(3) isn't a terrible problem as I can still use the physical mouse to move the cursor, and just use the numpad to register the left and right clicks. However, (2) is slightly annoying and (1) is extremely annoying. I've seen another forum post say that Ctrl+Shift+NumLock will also toggle MouseKeys, but that was old and does not seem to work on my system.

Should problems (1) and (2) be listed as bug reports? If not, then is there a command line method to enable and disable MouseKeys? And is there an option on this command to modify the movement speed of the mouse?

Btw, I'm using Ubuntu 14.04 LTS.

1

Please give this article a look, it is potentially a duplicate or at least a similar issue:

Turn Mousekeys on/off from keyboard

  • Yeah, you're right. That answer fixed it. However, does this still warrant a bug-report? Issue (2) seems to be a bug. – Artezanz Jun 13 '16 at 19:45
  • I also found askubuntu.com/questions/150290/adjust-mouse-keys-in-12-04 as an answer to solve the low speed issue. – Artezanz Jun 13 '16 at 19:57
  • I definitely think anything that is buggy warrants a bug issue! I used to think I was nagging until I realized that the entire Linux community is built off the very principal that we all report our findings and help improve... That's open source! And, no need to worry about bugging the people, it's a tough crowd sometimes :) Cheers! – P Smith Jun 13 '16 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.