4

Having a bit of a strange issue on 16.04. I just got some new speakers for the office (3.5mm jack), but unfortunately they don't seem to be recognized by my computer. I also have a Yeti microphone that's plugged in via USB.

When the microphone is plugged in, Sound settings shows only the microphone as a valid output device. I can select it and play sound through headphones connected to it, but can't make sound come through the speakers no matter what I try. This screenshot shows my sound settings when the mic is plugged in:

enter image description here

When the microphone is unplugged, no devices are listed under Sound settings for Output, but the sound will play through the speakers just fine.

The issue is that I would like to use the microphone as a microphone, and run my audio output through the speakers now. How do I get my computer to recognize the speakers as a valid device with the microphone plugged in?

  • have you tried using pavucontrol ? it has a lot more options for configuring pulseaudio devices – Amias Nov 10 '16 at 13:38
  • @Amias Well, with pavucontrol I can get sound to play through the speakers, but I still don't see the speaker in the volume control settings. Will I always have to use pavucontrol to change audio output devices, then? – Ryan Nov 10 '16 at 15:13
  • it sounds like a regression , i would raise it as a bug – Amias Nov 10 '16 at 18:07
  • @Amias well, if you'd like to post a short answer with how to do it with pavucontrol, that looks like the best answer I'm going to get. – Ryan Nov 15 '16 at 17:33
  • Do you have a 3.5mm port that only accepts microphone? I feel the problem here is that the speaker priority for your microphone is higher than that for your speakers, and, while I don't have the knowhow to fix that issue, just moving the pin to a port that cant send audio should 'fix' it, at least as far as functionality goes. – Girish Manjunath Nov 16 '16 at 13:44
1

Installing and opening pavucontrol, I was able to configure the computer to use the speakers as an audio device. They still don't show up as a device in the normal sound settings, but Ubuntu is successfully using them to play music, and that has stayed the default over a few reboots. I think as long as I don't touch anything, it should work.

Still don't know why it's not showing up under Sound Settings, but at least it's working.

-1
+50

have you tried using pavucontrol ? it has a lot more options for configuring pulseaudio devices.

something looks odd with your microphone presenting an spdif output, have your verified it works ok with other devices ?

  • The microphone has an output. I can plug headphones into it and hear just fine, but I'd rather plug things into my speakers. – Ryan Nov 16 '16 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.