7

I used the cntlm proxy for authentication against a ntlm proxy server in the past. While this worked seamlessly in 14.04, now I get some Hash Sum mismatches when trying to sudo apt update. I also tried all suggested solutions like clearing the cash or removing /var/lib/apt/partials/*. Firefox and other terminal applications work fine, environmental variables are set correct.

I think this has something to do with the upgrade to apt 1.2 happened in 16.04.
I don't know, if this can be fixed by configuration somehow. And if not, can you tell me where to file this bug, or any other information to apt 1.2? What changed in the update and could be causing this problem?

Do you know any other methods to teach ubuntu the ntlm protocol for authenticating against such proxies?

It is really important for me to get this working, because without cntlm I will have to use windows. This really can't be a viable solution ;)

EDIT: I tried this with a fresh installation of 16.04. So with upgrade I don't mean upgrading the same installation, but setting up a new one.

6

Looks like a bug in apt 1.2.

I could resolve this by adding the following lines to /etc/apt/apt.conf as suggested here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=810796

Acquire::http::No-Cache true;
Acquire::http::Pipeline-Depth 0;
1
  • In my case it doesn't actually seem to be a defect in apt but a buggy proxy server. Still, this helps. – 0xC0000022L Aug 7 '19 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.