0

I keep getting

W: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found 

when I do a apt-get update, also get failed to download repository information when i try software update.

How do i fix these?

  • Hopefully you have an active internet connection and that your connection isn't restricted and that – Zuko Jun 13 '16 at 5:03
  • 1
    There are no installation candidates for Trusty for this PPA. – edwinksl Jun 13 '16 at 6:05
1

It seems like you are using a non valid ppa

1. Disable the PPA

Please disable (by unchecking or removing) the gwibber ppa via Software & Updates (from Terminal: software-properties-gtk) in the Other Software tab

enter image description here

This AskUbuntu post explains removing PPA's as well.

2. Update package informations

Now open a Terminal and re-run

sudo apt update 

or

sudo apt-get update

to update your package informations.

3. Install updates (optional)

You should then be able to run

sudo apt upgrade 

or

sudo apt-get upgrade

to upgrade your packages as well.

Regarding the gwibber daily ppa

If you try to open up the ppa url in your browser you'll see as well that the entire url seems non existent.

I've checked the project url and it seems like precise is the last supported Ubuntu release for this ppa. I can only guess what you are using (trusty) as you haven't mentioned it in your post.

| improve this answer | |
0

From a terminal use --remove flag to remove the PPA:-Similar to how the PPA was added
sudo add-apt-repository --remove ppa:whatever/ppa
FAs a safer alternative, you can install ppa-purge
sudo ppa-purge ppa:whatever/ppa
Alternatively hit Alt+F2 and run software-properties-gtk Software Sources

Click on Other Software tab, you'll see that each PPA have two lines here, one for the compiled packages and one for the source, Uncheck both lines to disable a PPA.Then update your sources list
sudo apt-get update
and try to upgrade again
sudo apt-get upgrade

| improve this answer | |
0

I had the same problem aswell, I solved it by running "software-properties-gtk", then go to "ubuntu software" tab and select another server from " download from" drop-down menu. In my case I chose Duke server in the US.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.