I have installed Webmin with the view to try an understand what is all running.

Yesterday I had it setup with login and password, but today when I try to get access to the server with: https://ubuntu:10000/ in order to login, I get unable to connect, the page does not load. Seems like there is no connection.

  • I tried http://localhost:10000 and https://localhost:10000 They both returned the same unable to connect response.

I am not sure of what it means to turn https on. ... the https and http is not showing.

Am I going about this the wrong way?


If you did not setup webmin with https you need to to connect using http://localhost:10000 instead of https://localhost:10000.

If webmin is not starting by default on your computer you need to create a script in your /etc/init.d with this content, call the script webmin

# chkconfig: 235 99 10
# description: Start or stop the Webmin server
# Provides: webmin
# Required-Start: $network $syslog
# Required-Stop: $network
# Default-Start: 2 3 5
# Default-Stop: 0 1 6
# Description: Start or stop the Webmin server


case "$1" in
    $start >/dev/null 2>&1 </dev/null
    if [ "$RETVAL" = "0" ]; then
        touch $lockfile >/dev/null 2>&1
    if [ "$RETVAL" = "0" ]; then
        rm -f $lockfile
    pidfile=`grep "^pidfile=" $confFile | sed -e 's/pidfile=//g'`
    if [ "$pidfile" = "" ]; then
    rm -f $pidfile
    pidfile=`grep "^pidfile=" $confFile | sed -e 's/pidfile=//g'`
    if [ "$pidfile" = "" ]; then
    if [ -s $pidfile ]; then
        pid=`cat $pidfile`
        kill -0 $pid >/dev/null 2>&1
        if [ "$?" = "0" ]; then
            echo "$name (pid $pid) is running"
            echo "$name is stopped"
        echo "$name is stopped"
    $stop ; $start
    echo "Usage: $0 { start | stop | restart }"
exit $RETVAL

make this executable with sudo chmod 755 /etc/init.d/webmin and add it to the startup procedure with update-rc.d webmin defaults. After this webmin will start with your computer.

To avoid all these small things you can also download webmin as a debian package that you can install in your system.

Fist you need to remove the current webmin tar install


Then install all webmin dependencies

sudo apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python

Download the latest deb file from here or use this command to download the current latest version (up to this date)

wget http://dfn.dl.sourceforge.net/project/webadmin/webmin/1.570/webmin_1.570_all.deb

After downloading the file you can install it with

sudo dpkg -i webmin_1.570_all.deb

webmin will install, configure all necessary scripts and be ready for you in https://localhost:10000 all the time so you can login with your username / password.

  • I just tried it and it returned the same result, namely: Unable to connect. ... thanks. – railguage48 Nov 12 '11 at 21:21
  • I tried 'localhost:10000' and 'locahost:10000' and they both returned the same unable to connect response. I am not sure of what it means to turn https on. ... the https and http is not showing. ... thanks. – railguage48 Nov 12 '11 at 21:26
  • I downloaded the tar from www.webmin.com and followed the installation instructions ... it all worked yesterday:) .... thanks – railguage48 Nov 12 '11 at 21:37
  • I just found a way ... not sure if it is the correct way, but here goes ... sudo /etc/webmin/start .... then one logs onto the server with localhost:10000, and walla I'm in webmin.... thanks .... edit .... the https is not showing but that should precede the //localhost:10000 – railguage48 Nov 13 '11 at 0:50
  • updated answer to reflect your comments. tested on a running system so hope there are not typos around ;) have fun and gl. – Bruno Pereira Nov 13 '11 at 10:07

I know this is an old thread, but nonetheless I had a similar problem and my solution was to ensure port 10000 was accepting connection. So if you are having a similar problem, you may want to try this. Connect to your server through SSH and execute the following command:

sudo iptables -A INPUT -p tcp -d 0/0 -s 0/0 --dport 10000 -j ACCEPT

For me it worked instantly. Good luck.


Forgot to mention, you should save your iptables after adding your new rule, this can be done by running sudo service iptables save on your command line. Otherwise on server reboot, any changes done in your iptables will be lost. If that doesn't work, you can try sudo /sbin/service iptables save.

  • For me, a bit different rule did the trick: sudo iptables -A IN_public_allow -p tcp -m tcp --dport 10000 -j ACCEPT – Jānis Elmeris Sep 28 '17 at 9:01
  • However, it got lost after server restart. So, actually, the solution was, at first, to manually add the rule above, then log in to Webmin, go to "Un-used Modules" -> "FirefallD", make sure "Show rules in zone: public" is selected, click on "Add allowed port" ("Webmin" itself is not defined in the services to add it as a service), enter "10000" as the port, create and then "Apply configuration". – Jānis Elmeris Sep 28 '17 at 9:37
  • Good, yes, you have to save it by running sudo iptables save otherwise on reboot it will not add the rule. Adding this to my answer. Glad you got it working. – ColdTuna Sep 28 '17 at 15:58
  • Another thing: if I install Webmin using Virtualmin's setup script, the additional FirewallD rule (along with many others) are added for me, thus another solution: install Webmin by installing Virtualmin. :) – Jānis Elmeris Sep 28 '17 at 20:40

Try changing the port and listen in \etc\webmin\miniserv.conf



Then restart webmin:

/etc/init.d/webmin restart

Now use:


mine did this same exact thing after a reboot and i was able to access it by using the domain name of my modem/router (ex. https://myservername.routername.com:10000)

  • 3
    @maythux "and i was able to access it using the domain name of my modem/router" So you see, this is an answer, and not a "me too" post. It just looks like a "me too" post for the first few words. – Eliah Kagan Oct 3 '12 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.