0

When I click on (plugin) update now it is blocked and I am re-directed to the update now button to update Java.

I updated Java to version 8 update 91. I followed the instructions about removing the link to the old plugin and updated the link in ~mozzilla/plugins to point at the new plugin. I restarted Firefox (rebooted also). Still no luck.

I removed packages jre and jdk so I had only java 8 running. Same issue... I cannot remove or update the plugin in Firefox.

todd@todd-GX270:~$ java -version
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) Client VM (build 25.91-b14, mixed mode)

todd@todd-GX270:~/.mozilla/plugins$ ls -alc
total 8
drwxrwxr-x 2 todd todd 4096 Jun 12 14:39 .
drwxr-xr-x 5 todd todd 4096 Jun  8 21:31 ..
lrwxrwxrwx 1 todd todd   51 Jun 12 14:39 libnpjp2.so -> /usr/lib/jvm/java-8-oracle/jre/lib/i386/libnpjp2.so

Should I remove Oracle Java 8 and go back to JRE or JDK that was previously installed (part of Ubuntu I think)?

0

Updating the Java Plugin within Firefox itself doesn't work in Linux, you have to downlad the latest Oracle JDK or JRE and link to the new Plugin as described below.

Close Firefox and open the Terminal:

cd .mozilla/plugins   
sudo rm -rf libnpjp2.so 
ln -s /path-to-jdk-or-jre-firefox-plugin/libnpjp2.so .

Replace 'path-to-jdk-or-jre-firefox-plugin' with the real path to your latest jdk or jre on your computer. Don't forget the '.' at the end of the above line!

Start Firefox and chek in 'about:plugins' or 'Tools → Add-ons'

This should work, if the path to the plugin is correct...

  • Hi Neni - I was pretty sure that this was exactly what I did. I redid exactly what you said and I still have the problem.<p> When I look at about:plugins it has <p> Java(TM) Plug-in 10.67.2 File: libnpjp2.so Path: /usr/lib/jvm/java-8-oracle/jre/lib/i386/libnpjp2.so Version: 10.67.2 State: Enabled (STATE_VULNERABLE_UPDATE_AVAILABLE) Next Generation Java Plug-in 10.67.2 for Mozilla browsers <p> – Bob Todd Jun 14 '16 at 1:53
  • I thought I had only 1 version of java. java -version shows todd@todd-GX270:~/.mozilla/plugins$ java -version java version "1.8.0_91" Java(TM) SE Runtime Environment (build 1.8.0_91-b14).... could that be where that plugin is coming from? Java HotSpot(TM) Client VM (build 25.91-b14, mixed mode) If I look at /usr/lib/jvm I see todd@todd-GX270:~/.mozilla/plugins$ ls /usr/lib/jvm/ java-6-sun java-6-sun-1.6.0.26 java-8-oracle – Bob Todd Jun 14 '16 at 2:02
  • hmm, your plugin is pretty old... I would suggest you to download the latest jdk or jre (link is in the answer) manually and do the link with this new folder... if it works, do the other procedures (update-alternatives...) with this folder and delete all the others... – Neni Jun 14 '16 at 6:21
  • I did all that already. I will get rid of the sun javas. They may be interefering. – Bob Todd Jun 15 '16 at 0:44
  • I lost again. I removed Sun java 6 and now only have the following installed. – Bob Todd Jun 17 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.