2

I am having trouble adding the correct resolution for my second monitor. Both of my monitors worked fine in windows and I'm not going back :)

I am running a single GTX980 with one monitor connected via DVI, and one monitor connected via HDMI-DVI cable (HDMI end is connected to graphics card, DVI end is connected to monitor. The monitor connected via single DVI(my main monitor) is working fantastically. It's the second monitor that is not picking up the correct resolution.

So this is the output of xrandr

DVI-I-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1600x1200     60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   640x480       75.00    72.81    59.94  
HDMI-0 connected 1024x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00*+
   1360x768      59.96    59.80  
   1152x864      60.00  
   800x600       72.19    60.32    56.25  
   680x384       59.96    59.80  
   640x480       59.94  
   512x384       60.00  
   400x300       72.19  
   320x240       60.05  

The maximum resolution of the second monitor is 1440x900, which was picked up fine in windows, so I tried the following.

cvt 1440 900
# 1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz
Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync

xrandr --newmode "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync

But when I do this:

xrandr --addmode HDMI-0 1440x900_60.00

I am greeted with:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  47
  Current serial number in output stream:  48

Edit: I am still researching what I can and will add anything I find below.

Monitor Model: Dell S199WFP

xrandr --verbose output

  • Welcome to Ask Ubuntu. Nice that you have already solved it by yourself. Would accept your own answer as that what works for you, see askubuntu.com/help/someone-answers , BTW, could you post the output of xrandr --verbose to paste.ubuntu.com . I want to confirm if the monitor send the id & sync information. – user.dz Jun 16 '16 at 19:49
  • 1
    @Sneetsher Sorry for the late reply. Here you go! paste.ubuntu.com/17555525 – Aaron Rubesh Jun 19 '16 at 18:53
  • The output shows missing EDID data on HDMI port, Either adapter/cable problem or disabled from monitor. You can verify monitor > main menu > factory reset > DDC/CI ? – user.dz Jun 19 '16 at 19:26
  • 1
    @Sneetsher hmm. It may be because I'm using an HDMI -> DVI cable? – Aaron Rubesh Jun 23 '16 at 3:15
  • Yep, That's what I thought. Most probably is due that cable. – user.dz Jun 23 '16 at 3:18
1

So I googled around a little more and after trying a few things I found that xrandr doesn't quite work well nvidia proprietary drivers, so I had to use :

sudo nvidia-xconfig

to generate a xorg.conf in /etc/X11/xorg.conf

I then googled around for the HorizSync and VertRefresh values for the monitor in question which I found to be:

HorizSync     30 - 83
VertRefresh   56-75

So I found in my xorg.conf where the monitor was, at this block and made the changes:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30 - 83
    VertRefresh     56 - 75
    Option         "DPMS"
EndSection

then I restart lightdm:

sudo systemctl restart lightdm

Checked the display settings again and...Bam! there is was.

Display resolutions fixed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.