My touchpad working good in ubuntu live but dont work after installation

here is some info from live/pendrive

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input8
U: Uniq=
H: Handlers=mouse1 event7 
B: PROP=9
B: EV=b
B: KEY=6420 30000 0 0 0 0
B: ABS=260800011000003

    enter code here

$xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SIGMACHIP Usb Mouse                       id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ HD WebCam                                 id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                          id=14   [slave  keyboard (3)]

$dmesg | grep ouch
input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input8

but after installation

$xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SIGMACHIP Usb Mouse                       id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ HD WebCam                                 id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys 

has no such device, my touchpad not working, i have also tried folling:

1.Installing after removing usb mouse, but did not worked either 2.GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash"
3.modprobe -bla -bla mouse

any help

closed as off-topic by Eric Carvalho, Zanna, mikewhatever, TheWanderer, Byte Commander Oct 16 '16 at 23:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Zanna, mikewhatever, TheWanderer, Byte Commander
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    After restarting few times it came back, i dont know how it came, probably i started windows then came back to ubuntu. – kdm6389 Jun 13 '16 at 7:59

Edit 50-synaptics.conf file :

sudo nano /usr/share/X11/xorg.conf.d/50-synaptics.conf

Add the following line:

MatchIsTouchpad "on"

Option "TapButton1" "1"

Like this:

Section "InputClass"

Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
Option "TapButton1" "1"
Option "VertEdgeScroll" "1"

Save , exit and reboot

Not the answer you're looking for? Browse other questions tagged or ask your own question.