1

I am using Ubuntu14.04 to compile openjdk,when I run "make sanity" met two ERROR . This problem has been consumed for several days,how can I fix them?

ERROR: FreeType version  2.3.0  or higher is required. 
 make[2]: Entering directory `/home/lzw/test/openjdk/jdk/make/tools/freetypecheck'
/bin/mkdir -p /home/lzw/test/btbins
rm -f /home/lzw/test/btbins/freetype_versioncheck
make[2]: Leaving directory `/home/lzw/test/openjdk/jdk/make/tools/freetypecheck'
Failed to build freetypecheck.  

ERROR: You do not have access to valid Cups header files. 
       Please check your access to 
           /usr/include/cups/cups.h 
       and/or check your value of ALT_CUPS_HEADERS_PATH, 
       CUPS is frequently pre-installed on many systems, 
       or may be downloaded from http://www.cups.org 

Exiting because of the above error(s). 
3
  • Did you try what the error message suggests?
    – wie5Ooma
    Jun 12, 2016 at 2:53
  • Thank you ! I found some sulotion like this askubuntu.com/questions/663810/… ,but it dosn't help. I don‘t know what to do now..
    – Jayven
    Jun 12, 2016 at 3:01
  • 14.04 appears to provide libfreetype6-dev version 2.5.2: have you installed it? BTW why do you need to build openjdk? Jun 12, 2016 at 3:16

1 Answer 1

2

Even though I'm using Fedora, simply installing cups-devel solved the problem. Try installing the equivalent on Ubuntu.

sudo apt-get install libcups2-dev

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .