3

I run a dual boot of Ubuntu and Windows.

Windows running f.lux has a noticeable effect.

I have redshift and flux installed on Ubuntu but neither has an visible effect.

I'm looking for help in debugging this or any alternative software to make the light less harsh on the eyes.

Installation of flux from ppa see here: f.lux setup.py on xubuntu 16.04 results in error

While I believe I installed redshift from the software installer app.

Typing in redshift into terminal results in this.

Trying location provider `geoclue'...
Started Geoclue provider `Geoclue Master'.
Using provider `geoclue'.
According to the geoclue provider we're at: 43.64, -79.39
Gamma ramp size too small: 0
Failed to start adjustment method randr.
Trying next method...
Using method `vidmode'.

And it just seems to stall from there.

The details of package for redshift installed from the Ubuntu Software Centre says this package provides gtk+ integration.

xrandr output:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
1920x1080      77.0* 

redshift -v results in the same thing as redshift but followed by

Status: Enabled
Period: Night
Color temperature: 6500K
Brightness: 1.00
Period: Night
Color temperature: 6471K
Brightness: 1.00

Then the same combo of 3 statements, with color temperature decreasing until it reaches 3700k, and it just repeats the fact it's at 3700k

Period: Night
Color temperature: 3700K
Brightness: 1.00

No redshifting visible effect as far as I can tell, still.

Results of lspci | grep VGA

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc.
[AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E]

I think I should I have the correct (proprietary) drivers installed.My video drivers settings?

  • How did you install it on Ubuntu? – edwinksl Jun 12 '16 at 1:14
  • what is the output of xrandr and redshift -v? – Paul Jun 16 '16 at 1:23
  • Added output of xrandr and redshift -v to original post – user1821961 Jun 16 '16 at 1:44
  • do you have the proper video drivers installed? what is your video card? this can be found with lspci | grep VGA – Paul Jun 17 '16 at 3:38
0

Another option is to install xcalib via sudo apt-get install xcalib

Then, you can invert the screen colors which again maybe too harsh because black will become white or, and this is what I prefer, you could reduce the screen contrast using

xcalib -co 75 -a

or any other value you feel comfortable with.

And you could reverse the effect with

xcalib -c

Obviously, you could set up a keyboard shortcut for the above to save typing in a terminal. How exactly you add the keyboard shortcut depends on your distro.

  • Ran xcalib with sudo, no visible effect as far as I can tell. – user1821961 Jun 12 '16 at 20:07
  • What about without sudo? Does it work for you there? Do you need to use sudo a lot for prolonged periods? – DK Bose Jun 13 '16 at 1:40
  • I tried without sudo before trying with sudo, no effect in both cases. – user1821961 Jun 16 '16 at 0:56
0

You need both redshift and redshift-gtk installed if you want to control it out of the terminal. If you want to just keep redshift, open up a terminal, enter redshift, press Enterand wait until it boots. To open it automatically after login, you'll need to open up the Startup applications app and add redshift if it isn't already there. You might as well skip this last step and see if it works by logging out and back in.

  • I've edited in the results of trying to run redshift from terminal into my original post, as well as the fact that I believe I have both installed. – user1821961 Jun 16 '16 at 0:56
0

I was having the same problem with my new installation of Ubuntu 16.04. Flux & redshift would not work at all. This is what worked for me, your mileage may vary: So I was having a different problem with my sound card and when I completely removed PulseAudio and all its dependencies, and purged apt-get, flux started working automagically! I then reinstalled the PulseAudio system and reinstalled the desktop and flux is still working!!! Hopefully someone else will have the same luck I did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.