I'm new to Ubuntu so go easy on me. I've heard great feedback and support from these forums so I'm crossing my fingers.

I booted ubuntu 16.04 on my new custom build pc, I went through all the installation steps and rebooted my system.

However, when i get to the log in screen, i enter my password and the desktop then flashes quickly, briefly seeing the Ubuntu logo and its version and then parts of the desktop template fade away and I am just left with the desktop wallpaper and the mouse, nothing else, no other options.

I can open terminal with ctrl + alt + 1 and I have tried various commands to fix the issue after reading the threads here, especially this one Ubuntu 16.04 Unity No desktop just background wallpaper I get the line 'compizconfig-settings-manager' has no installation candidate so that's no good

I feel like the video drivers may be an issue and i need to update them but the command line says everything is updated.

Can anyone help me with this I am very stuck and need a working computer ASAP. Much thanks to anyone. Here is my pc build: MSI GTX 970 Intel I5 6600k Asus z170 Deluxe MB Samsung 950 PRO SSD

  • after reading all comments, this is fresh install, and computer is not connected to internet,and you have black screen..to me now,all look that nvidia driver is not loaded..so display not work.. you allredy reinstall compiz,do same for nvidia ,purge and reinstall open source nvidia driver..and please enable internet,with simple plug in internet cable,so after we can fix ur wifi..more easy thrue desktop..not from terminal..
    – siniša
    Jun 12, 2016 at 1:23
  • please look here askubuntu.com/questions/760043/…
    – siniša
    Jun 12, 2016 at 1:26
  • 1
    same problem ,and Nvidia,and is solved here →→ askubuntu.com/questions/449845/…
    – siniša
    Jun 12, 2016 at 1:30

3 Answers 3


so you have access to terminal, and you all ready do apt-get update,apt-get upgrade type compiz in terminal to start it, then type unity.. if that not give you graphical desktop, type reboot,and when computer do rebooting,press and keep left shift button on keyboard to enter in recovery mode.. from there chose 1st to enable networking,and be sure that cable of Ethernet(internet)is in.. and then do recovery ..basically from there we can all,but we need to know if you came there.. yes,i am going easy on you..to not push too much commands..dont worry.. to me seems that Nvidia driver(gpu driver is not activated..) but we will see after from terminal for sure,if you installing for 1st time,then is better(faster,easier) to do reinstall,then to fix this.. as for fixing we need to know what is wrong..from terminal output.. or read output pasted to paste-bin or similar service.. really reinstall is more easier option in your case, as fixing is worth time consuption only when we save data,or when we deal with system what was working..not for fresh install..i crash my system for purpose,so many times..only i am not familiar with exact nvidia drivers..but for start to get thing working use open source drivers,and after you can change to closed source,as i believe that is what you what to use with gaming class card..yep,will be nice to check if nvidia driver is loaded..but above all to read log files..maybe you overlook something,some step during installation..and yes tell us is this fresh installation or upgrade? if is upgrade then from what previous version of ubuntu?

  • Ok, I'm a little confused. I tried that unity command and it will not update (not installed package). I'm totally up for reinstalling this if it would fix my issue. I am booting from a usb, using a mac with Unetbootin to create the boot on the usb. Would it help if I got a different version of Ubuntu or even a different flavour of linux?
    – kgren
    Jun 12, 2016 at 0:50
  • just type compiz then enter,then type unity then enter,then you can again compiz .. diff.flavors just change type of desktop manager,and can be more easy on resources(but you have strong hardware,so you can choose whatsoever), and is this after upgrade,or you install ubuntu for 1st time on that machine?
    – siniša
    Jun 12, 2016 at 0:56
  • This is a fresh installation of Ubuntu, when i typed compiz 5 lines popped up, the middle one was Fatal: couldn't open display
    – kgren
    Jun 12, 2016 at 0:59
  • will be nice if we can read that lines,but i think must say something about "copiz core" plugin loaded or not, and about "display manager"..do this press left ctrl and left alt and keep it both pressed then press from F1,F2,up to F7.. can you? commands we will execute with sudo,as root, and display normally is on F7..really its better that you reboot to "recovery mode"(but with networking) as there is only root,can you? and are you connected with cable?(to not adjust one more thing..)as we gonna re download from internet,some packages again..
    – siniša
    Jun 12, 2016 at 1:09
  • F1 F2 and F7 all work but when i do the F7 i just go back to the blank desktop screen. Do you reboot from recovery mode by typing reboot then long pressing left shift? because that hasn't worked for me. I'm not sure how to connect to the internet, and ethernet is not an option.
    – kgren
    Jun 12, 2016 at 1:13

There is the option to try reinstalling Ubuntu all over again.

From the comments & answers there are a number of things that are going wrong. Compiz is complaining and giving you a blank desktop & you don't have an internet connection which would be needed to reinstall compiz for example.

Being able to update & reinstall packages is in most of the possible solutions to 'fix' your current problems.

Try running the live USB without installing and see what works 'out of the box'. Does the live USB show the desktop without any problems? Are you able to connect to Wi-Fi?

These things will let you see if there is a problem with just this particular attempt at installing or if your setup is tricky (e.g a graphics card or Wi-fi that will require additional drivers).

It's not that it can't be fixed, but without Wi-fi working a lot of options to 'narrow down' where the problem lies (by reinstalling the Unity Desktop or Compiz for example) will not be possible.


Have you tried reinstalling unity? That is the main Ubuntu UI program. If that is unsuccessful, try doing

sudo apt-get purge compiz && sudo apt-get install compiz
  • I tried reinstalling Unity, but same issue. I ran that code and got the following message after a bunch of lines ran E: Package 'compiz' has no installation candidate. What do i do now?
    – kgren
    Jun 12, 2016 at 0:18
  • It looks like you may have somehow ruined your software sources. Try using 'sudo apt-get update' and post the output.
    – PMiner
    Jun 12, 2016 at 0:21
  • Also, make sure you don't restart your computer because after uninstalling compiz, you won't have graphics after you restart.
    – PMiner
    Jun 12, 2016 at 0:24
  • I get a list of errors, 4 in total, they're all generally saying 'Temporary failure resolving 'ie.archive.ubuntu.com'' and failed to fetch .... Some index files failed to download
    – kgren
    Jun 12, 2016 at 0:25
  • I have an msi gtx 970, no that does nothing, i only can use ctrl + alt + F1
    – kgren
    Jun 12, 2016 at 0:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.