Just installed a fresh Ubuntu 16.04, and Samba. I want to share a drive with Windows machines, with anonymous users.

First thing I notice is the Samba configuration GUI (system-config-samba) is no longer available.

I forged ahead with the CLI and Nano, editing /etc/samba/smb.conf, using various bits of information from many other people struggling with the same issues.

I have it to the place where Windows machines can see the machine and the shared folder, but any attempt to open the share results in "Access Denied". I want the share to be anonymous, but I also tried logging in using the Ubuntu user and password, and still "access denied".

Before I get into all the gory details after several hours of trying, what happened to the GUI config? If it is just under another name, I'll try that first.

Update: It turns out there is an even easier way to configure sharing in 16.04 Unity. Just right click on the folder to share and select "Local Network Share". From there, the Folder Sharing dialog opens to configure the sharing.

Unfortunately it doesn't work (remote user authentication always fails), but at least the interface is there. I'll report back if and when I figure out more.


5 Answers 5


To get a GUI to configure Samba I installed system-config-samba. It was crashing. I looked around a bit… What worked for me was creating the missing file libuser.conf in /etc. So I typed in terminal:

sudo touch /etc/libuser.conf

Source: https://ubuntuforums.org/showthread.php?t=2250379

  • Same problem here. For the record, still working solution under Lubuntu 17.10. Thanks. Apr 14, 2018 at 17:36
  • Ubuntu 18.04 in almost 2019. Still sucking. Saved me Dec 26, 2018 at 16:53

Simply right click the folders in your home and enable local share, it will offer to install samba files. After that, in a terminal run sudo smbpasswd -a username (where username is existing UNIX username) and set your password and reboot.

  • 1
    Bingo - smbpasswd was the issue. I've been through configuration guides for Samba, and I guess I missed the fact that Samba keeps a separate database of users and passwords. That explains why it rejected the login with a valid linux username and PW. I still don't know why anonymous login doesn't work - that's what I was trying to accomplish.
    – tim11g
    Jun 14, 2016 at 18:10
  • 1
    Earlier libpam-smbpass would synchronize your existing password with samba password but that has been taken out. Jun 15, 2016 at 1:56
  • Thanks a lot. I configured file sharing in nautilus but was unable to access any folders I shared. It works after I added the samba user! (I thought they would add my current user as a samba user by default)
    – Liu Siyuan
    Nov 26, 2016 at 8:28
  • No need to reboot either. Simply adding user does the trick.
    – Jus12
    Jul 9, 2017 at 19:15

Installing system-config-samba is not a problem. I installed it using synaptic - just clicked "mark for installation" and "apply" and bingo. The problem is that once installed, it does not work. First, it doesn't show up in the launcher, or the classic menu, or in system settings. (At least, I can't find it.) Second, when run from the command line, it produces the following error message:

duncant@linuxbox:~$ system-config-samba0
Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 45, in <module>
  File "/usr/share/system-config-samba/mainWindow.py", line 116, in __init__
    self.samba_user_data = sambaUserData.SambaUserData(self)
  File "/usr/share/system-config-samba/sambaUserData.py", line 46, in __init__
  File "/usr/share/system-config-samba/sambaUserData.py", line 63, in    readSmbPasswords
    raise RuntimeError, (_("You do not have permission to execute %s." % pdbeditcmd))
RuntimeError: You do not have permission to execute /usr/bin/pdbedit

Doesn't work when run with sudo privilege either:

duncant@linuxbox:~$ sudo system-config-samba
[sudo] password for duncant: 

(system-config-samba:15161): IBUS-WARNING **: The owner of /home/duncant/.config/ibus/bus is not root!
Traceback (most recent call last):
  File "/usr/sbin/system-config-samba", line 45, in <module>
  File "/usr/share/system-config-samba/mainWindow.py", line 121, in __init__
    self.basic_preferences_win =   basicPreferencesWin.BasicPreferencesWin(self, self.xml, self.samba_data,   self.samba_backend, self.main_window)
  File "/usr/share/system-config-samba/basicPreferencesWin.py", line 97, in __init__
    self.admin = libuser.admin()
SystemError: could not open configuration file `/etc/libuser.conf': No such file or directory

However, I was able to get samba file sharing to work simply by right clicking on the folder I wanted to share in the ubuntu file manager, selecting Properties, then "Local Network Share".

This works fine for open guest access, but for authenticated access you also need to run the smbpasswd command.

So, bottom line, system-config-samba doesn't seem to work "out of the box" on ubuntu 16.04


The package system-config-samba is available at the universe repository. Enable the Community-maintained free and open-source software (universe) box at Software & Updates under Ubuntu Software tab. Then click reload after you close it.


I know this is a bit older but if anyone is interested in getting system-samba-config gui to work, then I wrote a script which does so. You can find it on github here

2021-May-06 Update: there is currently an issue with the wget urls used to install this deprecated library. You can follow that issue here; it looks like the python-gtk2 / python-glade2 maintainers might have pulled one of the deb file versions available for Ubuntu 18.04 and I haven't had time to do much analysis yet. I will update on my github first and here if i remember. If the downvote(s) on my answer scare you, that's entirely up to you. Personally, I think it has more to do with my post containing the word "Mint" - I have seen some overzealous fans of Ubuntu who don't read the rules carefully enough to take note that only questions must be strictly for Ubuntu and that distro-agnostic or derivative-distro answers are allowed as long as they are relevant... and have been downvoted by these types of people more than once. Still, up to you.

Personally, I recommend spending the time to learn how to edit /etc/samba/smb.conf. You shouldn't need to edit it that frequently and no workarounds to install deprecated software are needed. But I think very few people googling that care so I just answer the question :-)

The main issue was that system-samba-config was using gksu. my setup script creates a wrapper script then adds an exception to policykit so that the gui will launch. finally, it updates the *.desktop shortcut so that it launches using the wrapper script rather than trying to still use gksu.

I use this on Mint ~~19.3 (based off Ubuntu 18.04)~~ Mint 20 but my script doesn't contain anything Mint-specific or even Cinnamon DE-specific. Policykit is used on both Ubuntu and Mint. Desktop files are used by many DE's/distos an I believe /usr/share/applications is where *.desktop files live in both as well. Even if it doesn't work on Ubuntu for some strange reason, it would be a decent reference for anyone really wanting this. As long as system-samba-config is available in the repos, it should work. Pretty sure I was using this on Mint 18.3 (based on Ubuntu 16.04) at one point as well.

to use my setup script:

git clone https://github.com/zpangwin/linux-setup-scripts.git;
find linux-setup-scripts -type f -iname '*.sh' -exec chmod a+rx "{}" \;;
cd linux-setup-scripts/mint-20.x/apps/deprecated-system-config-samba

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .