2

I'm trying to connect a Nexus 7 tablet (Android 6.0.1) from Ubuntu 14.04 LTS.

I started by following the instructions from this answer. When I execute the last command android-connect, it tells me:

Unable to open ~/.mtpz-data for reading, MTPZ disabled.Listing raw device(s)
Device 0 (VID=18d1 and PID=4ee1) is a Google Inc (for LG Electronics/Samsung) Nexus 4/5/7/10 (MTP).
   Found 1 device(s):
   Google Inc (for LG Electronics/Samsung): Nexus 4/5/7/10 (MTP) (18d1:4ee1) @ bus 2, dev 4
Attempting to connect device
Android device detected, assigning default bug flags
Error 1: Get Storage information failed.
Error 2: PTP Layer error 02fe: get_handles_recursively(): could not get object handles.
Error 2: Error 02fe: PTP: Protocol error, data expected
Listing File Information on Device with name: (NULL)
LIBMTP_Get_Storage() failed:-1

Searching for a solution led me to this answer, which tells that:

  1. GVFS-MTP is required.

    In order to get the latest version of GVFS-MTP, I added, as instructed on another site, the corresponding PPA. Unfortunately, apt-get update terminates with:

    W: Failed to fetch http://ppa.launchpad.net/itachi-san/gvfs-mtp/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found
    W: Failed to fetch http://ppa.launchpad.net/itachi-san/gvfs-mtp/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    
  2. A bug in libmtp can be solved using a method explained in the author's blog, given that according to the author:

    The method outlined here is meant to be an experimental / quick fix for testing

    which is not particularly reassuring.

According to this other question, I have to:

  • apt-get install mtpfs, which I already did when following the instructions from the first linked answer,

  • Ensure that USB configuration is set to MTP. Did that, it was already set to MTP.

I also rebooted the PC and enabled and disabled USB debugging, unplugged/plugged the device and tried a different USB cable and different USB port, with no effect.

Is there something else I can try?

  • 1
    One way is to enable Samba sharing on Ubuntu, and install a file manager that can handle Samba on Android. It completely bypasses the usb-mtp issues. – mikewhatever Jun 11 '16 at 20:44
  • It should just work out of the box, make sure when you connect your tablet to select in the device notifications to transfer files(mtp) – xangua Jun 11 '16 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.