8

I saw similar questions, but unlike stated in other questions, My WiFi does not disconnect. Only the connectivity to Internet keeps dropping.

I have tried at different location (different WiFi), the problem is same. Any time I just disconnected from Internet (WiFi shows connected to network). After I reboot it works fine. Disconnecting and connecting to WiFi again does not help.

I have other devices (phone and mac) which have no such problem, so I am sure there is nothing wrong with the WiFi router.

EDIT: As requested here is the command output:

$ lspci -knn | grep Net -A2
02:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b4] (rev 93)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8270]
    Kernel driver in use: iwlwifi
9
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A2 terminal command.
    – Pilot6
    Jun 11 '16 at 18:08
  • Added the output to the question as requested. Jun 12 '16 at 14:05
  • You say: "After I reboot it works fine. ". Does that mean that after rebooting it works for as long as you need it no matter how long that is, or does it mean it works for a while and then the same thing happens again?
    – Stormlord
    Jun 12 '16 at 14:36
  • 2
    Run sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi disable_11n=1" and reboot.
    – Pilot6
    Jun 12 '16 at 15:17
  • 3
    I mistyped the command. Please do it again with this sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=1" You can also find my nswer with all options. You can try to pick one that helps.
    – Pilot6
    Jun 12 '16 at 17:56
6

Just so that we don't have an unsolved question which is actually solved by this comment by Pilot6

This command seems to work (it worked for me and the original poster):

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=1"
2
  • I have tried this fix. But still same issue. After I executed this tee command, nothing has been changed in iwlwifi-opt.conf file. Please help me. Jun 28 '17 at 16:17
  • I wasn't using my Ubuntu laptop for longer times as I was working on a different machine for almost a year now. Last few weeks I started using my Ubuntu laptop again and the problem is still there but there is no pattern. Some times it works for 3/4 hours without an issue, other times internet gets disconnected almost immediately after booting up. So the problem is not solved for me still. Oct 9 '17 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.