I have pretty much the same problem as in Dell XPS 13 9350 with Ubuntu 15.10 - Touchpad freezing, jumping - but on Ubuntu 16.04.

My touchpad stops working randomly, or can work somewhat only if I click and drag with it. Sometimes it starts working if I do a two-finger scroll, but this doesn't always work.

I have installed a mainline kernel (version 4.4.13-040413-generic) to fix an issue related to resuming after suspend. However, the present touchpad issue was present on a vanilla 16.04 install too.

Any help is appreciated. How would I even begin debugging this? (I am not shy to use the terminal or modify my system, as long as I know how to bring it back to a working version, in case the experiment fails).

  • what did you learn, DenverCoder9? – EvenLisle Oct 17 '18 at 14:00

I had the same problem when I put Ubuntu 16.04 on my Dell XPS13 (9350). For me the problem was largely resolved by installing libinput:

sudo apt-get install xserver-xorg-input-libinput

The only issue I have now is that the mouse pointer freezes once in a while. But this is very rare and I can always unfreeze it with a left click. Overall I'm very pleased with the improvement libinput has made to the performance of the touchpad.

You can read more about this solution at https://askubuntu.com/a/678122


| improve this answer | |
  • I tried this out for a week, but it doesnt seem to be helping. My touchpad still freezes but it's able to start working with a few clicks or by attaching a usb mouse. But there are instances where it doesnt fix itself. – donatello Jun 25 '16 at 11:50

I have experienced the same issue on my XPS 13 9350. I had the same issue about a year ago on my XPS 14 L421X. Dell updated the BIOS and then it was solved.

| improve this answer | |

I had a more extreme version of this issue on my XPS13-9333. After the update from the pre-installed 14.04 to 16.04, I had no touchpad anymore. Nothing would bring it back.

Updating the BIOS as per these instructions magically brought it back to life

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.