10

On a fresh install of 16.04, I am trying to install virtualenvwrapper by following this great answer by Gerhard Burger.

after configuring the .bashrc, whenever opening the terminal displays

bash: /usr/local/bin/python2.7: No such file or directory
virtualenvwrapper.sh: There was a problem running the initialization hooks. 

If Python could not import the module virtualenvwrapper.hook_loader,
check that virtualenvwrapper has been installed for
VIRTUALENVWRAPPER_PYTHON=/usr/local/bin/python2.7 and that PATH is
set properly.

the script location is,

$ sudo find / -name virtualenvwrapper.sh
[sudo] password for john: 
/usr/local/bin/virtualenvwrapper.sh

contents of my .bashrc are,

export WORKON_HOME=/home/john/.virtualenvs
source /usr/local/bin/virtualenvwrapper.sh
export PIP_VIRTUALENV_BASE=/home/john/.virtualenvs

here is my pip freeze

cffi==1.5.2
greenlet==0.4.9
pbr==1.10.0
readline==6.2.4.1
six==1.10.0
stevedore==1.15.0
virtualenv==15.0.2
virtualenv-clone==0.2.6
virtualenvwrapper==4.7.1

the python interpreter's location,

$ which python
/usr/bin/python

How do I make it work?

thank you.

  • Welcome to AskUbuntu. You might want to include a link to said answer you refer to :) – Videonauth Jun 11 '16 at 7:46
  • @Videonauth Thanks. I just removed the link while cleaning up. sorry. – All Іѕ Vаиітy Jun 11 '16 at 7:49
  • @John My /usr/local/bin indeed doesn't contain python2.7, and I suspect yours doesn't either. which python2.7 says /usr/bin/python2.7, but I have not yet figured out how to tell virtualenvwrapper to look in /usr/bin instead of /usr/local/bin. – edwinksl Jun 11 '16 at 8:04
  • @John Based on virtualenvwrapper.readthedocs.io/en/latest/…, can you add export VIRTUALENVWRAPPER_PYTHON=/usr/bin/python to your .bashrc before source /usr/local/bin/virtualenvwrapper.sh? – edwinksl Jun 11 '16 at 8:18
  • @edwinksl tried it, but it doesn't fix. – All Іѕ Vаиітy Jun 11 '16 at 8:20
15

I am using Ubuntu server 16.04, You should also export the python interpreter in which you've installed the the virtualenvwrapper

export VIRTUALENVWRAPPER_PYTHON=/usr/bin/python3
export WORKON_HOME=~/.virtualenvs
source /home/vagrant/.local/bin/virtualenvwrapper.sh

since I've got multiple python installation.

3

just comment

source /usr/local/bin/virtualenvwrapper.sh

line in

~/.bashrc

file....it worked for me.

1

You probably need to update your PYTHONPATH environment variable. In your .bashrc, before all the virtualenvwrapper variables, add the following line:

export PYTHONPATH=${PYTHONPATH}:/usr/bin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.