0

I cant login to the Ubuntu 14.04 but I can access the guest user.

If I enter the correct password, it flashes and comes back to the same login screen and if I enter wrong password it mentions invalid password (so I'm not entering the wrong password)

I used disks to auto mount one ntfs partition using this guide before the issue started and I used mount point as /home. So I wonder if thats the issue.

Can boot in to the recovery but login using ctrl+alt+F1 didn't work , it says incorrect login. I am dual booting Windows 7 and Ubuntu 14.04 and can access windows.

(I did go through other threads with same issues but none of them worked)

2 Answers 2

1

Selected recovery from grub menu. Selected root shell.

Remounted it in write mode

mount -w -o remount /

Edited fstab

nano /etc/fstab

Saved it and restated and it is working fine now.

0

Login as a guest user. Then look at the contents of /etc/fstab and delete the line with the mountpoint '/home' in it. You can do this by opening a terminal enter the command:

sudo nano /etc/fstab

Save the file. Then reboot and see if you can login. I don't know what you already tried to fix it but this could work. At the moment I can't test if you can edit fstab as a guest user so I'm not sure if it works.

You could also try the solutions in this post: Ubuntu gets stuck in a login loop The following command fixed it for me when my machine got stuck in a login loop.

dpkg-reconfigure lightdm

2
  • AFAIK guest logins can't use sudo or obtain the rights necessary to execute dpkg-reconfigure commands. They will need to boot into recovery mode and repair /etc/fstab from a root shell. Note that it will be necessary to remount the root filesystem in read-write mode before editing the file. Jun 11, 2016 at 13:12
  • You are right, can't use sudo in guest.so how can I repair fstab from root shell in recovery.I'm still at the early stages of Ubuntu, so step by step command guide will be helpful.thanks.
    – balus
    Jun 11, 2016 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.