8

Im sure veterans know the drill (as this question seems to have been asked a billion times), but I am getting this error while installing a piece of software ( ./configure )from source:

*** 'pkg-config --modversion glib-2.0' returned 2.48.1, but GLIB (2.48.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

and I have tried all of the fixes I found other threads to no avail... I have tried all the usual suggested PATH modifications, including but not limited to:

LD_LIBRARY_PATH=/usr/local/lib
PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig/
PKG_CONFIG_PATH=/usr/lib/pkgconfig/
PATH=/usr/local/bin:$PATH
ACLOCAL_PATH=/usr/local/share/aclocal/
export CPATH=/usr/local/include

And every possible combination where there is an option. I assume there is some diagnostic I can run to figure out where the hell my (real?) glib is hiding and how to point the program in question (or pkg-config) to it, but I have no idea what that would be.

Some output from commands suggested in another question of similar nature:

find /usr/ -iname "*glib*.pc" yields

find: ‘/usr/share/doc/google-chrome-stable’: Permission denied
/usr/lib/pkgconfig/glib-2.0.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/spice-client-glib-2.0.pc

and dpkg -l libglib2.0-dev yields

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
un  libglib2.0-dev <none>       <none>       (no description available)

For reference purposes, I tried the solutions (using that word rather liberally from the second thread) from here and here:

How to solve old GLIB error

How to solve old GLIB error while installing "pygobject" using jhbuild

and here:

https://stackoverflow.com/questions/11228173/how-to-find-where-older-version-of-glib-has-been-installed

and here and here:

http://www.linuxquestions.org/questions/linux-newbie-8/configure-requested-'glib-2-0-%3D-2-32-0'-but-version-of-glib-uninstalled-is-2-29-2-a-4175442396/

http://ubuntuforums.org/showthread.php?t=2002738

Ubuntu 16.04, for reference... I have been scrounging around and it looks like uninstalling glib and reinstalling is a no-no (system depends too heavily on it), but everything else is working fine for now... i am just struggling to install this new guy. Thanks!

  • I don't think there should be a problem uninstalling and reinstalling a -dev package. What does apt-cache policy libglib2.0-dev say? – steeldriver Jun 11 '16 at 13:35
  • @Ronald did you solve the problem? Someone else said it took them literally hours to resolve. I'm starting to think meld isn't worth the trouble – Nathan Apr 23 '18 at 1:43
3
+25

Your dpkg command doesn't catch everything. Try this command instead:

$ dpkg -l libglib2*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name              Version       Architecture  Description
+++-=================-=============-=============-=======================================
ii  libglib2.0-0:amd6 2.48.2-0ubunt amd64         GLib library of C routines
ii  libglib2.0-bin    2.48.2-0ubunt amd64         Programs for the GLib library
ii  libglib2.0-data   2.48.2-0ubunt all           Common files for GLib library

Although my Ubuntu 16.04 works perfectly for my needs it appears I have similar glib errors to you. I'll just ignore them though because I don't need to reinstall glib:

$ sudo apt install libglib2.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libglib2.0-0-refdbg' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil-dev' for regex 'libglib2.0'
Note, selecting 'libglib2.0-tests' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0-dbg' for regex 'libglib2.0'
Note, selecting 'libglib2.0-bin' for regex 'libglib2.0'
Note, selecting 'libglib2.0-cil' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dbg' for regex 'libglib2.0'
Note, selecting 'libglib2.0-dev' for regex 'libglib2.0'
Note, selecting 'libglib2.0-doc' for regex 'libglib2.0'
Note, selecting 'libglib2.0-data' for regex 'libglib2.0'
Note, selecting 'libglib2.0-0' for regex 'libglib2.0'
libglib2.0-0 is already the newest version (2.48.2-0ubuntu1).
libglib2.0-data is already the newest version (2.48.2-0ubuntu1).
libglib2.0-bin is already the newest version (2.48.2-0ubuntu1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-0-dbg : Depends: libglib2.0-0 (= 2.48.0-1ubuntu4) but 2.48.2-0ubuntu1 is to be installed
 libglib2.0-0-refdbg : Depends: libglib2.0-0 (= 2.48.0-1ubuntu4) but 2.48.2-0ubuntu1 is to be installed
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.48.0-1ubuntu4) but 2.48.2-0ubuntu1 is to be installed
                  Depends: libglib2.0-bin (= 2.48.0-1ubuntu4)
                  Depends: zlib1g-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

On one hand the messages say the most current version is already installed on the other hand it says incorrect versions are installed. At the end it says there are broken packages.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.