20

The Problem
I'm using LibreOffice 5.0.6.3 in Ubuntu 16.04, and the program is considerably slower than in e.g. Windows 8.1 and Debian 8.
This shows up in particular when I change the zoom level in larger documents below 200%. Above 200% (e.g. from 200% to 220% etc.), zooming in and out happens absolutely smooth -- the program needs no time for the change. But e.g. from 160% to 180%, zooming causes the program to get extremely laggy: Everything freezes, and sometimes also the whole program surface turns grey/black -- sometimes for some seconds, sometimes "permanently".
This does not happen when the edited document is relativley small; that is, when there are no objects, images etc. in it, but only text, or when the document is only a few pages long.

Example
I have an extensive document (50+ pages) with many arrows, tables, and also some pictures, and the problems mentioned occur when I open it in Ubuntu 16.04. But they don't occur when I edit the same document in Debian 8 and Windows 8.1.

What I've tried already
I already changed certain properties, since I searched quite a bit for possible solutions.
For example, I turned off Java and Open CL, and provided considerably more memory for LibreOffice. But all of this improved the situation hardly noticeably -- if at all...
...which is not really surprising, since in Windows 8.1 and Debian, LO ran smoothly without making these changes.

Question
Does anyone know whether this is an Ubuntu-specific problem, or simply why that occurs?
Could it have something to do with the fact that I'm not using the pre-installed version from Ubuntu Xenial? (I switched to the above mentioned version, since 5.1.x seemed to be even more unstable than 5.0.5 already was. (sudden crashes after simple commands))

2
  • I've noticed the same thing. Just opening a 20kb doc causes the program to hang. Commented Jun 10, 2016 at 19:53
  • I have the same issue, too slow when using Impress, i had to increase the memory but the same in result. Commented Mar 7, 2017 at 8:07

5 Answers 5

13

To avoid slow User Interface update, a workaround is to:

  1. Remove packages: libreoffice-gnome and libreoffice-gtk and libreoffice-gtk3.
  2. Restart (Close and Open) LibreOffice.

After this, LibreOffice User Interface is being updated fast. But, when (main) window is resized, sometimes it becomes messy. So, avoid any unnecessary resizes (resizings), keep (main) window in full size.

It seems to be a GTK port only issue.

Workaround was tested with LibreOffice 5.1.3.2 and Ubuntu 16.04 64 bit. Issue was fixed in LibreOffice 5.1.4.2.

8
  • I tried that, and it's true: it becomes very fast. But the user interface then looks like Windows 95 and also pretty small. Is there a solution for these new issues? By the way: The package 'libreoffice-gtk3' wasn't installed; the other two were. Commented Jun 20, 2016 at 20:51
  • GTK packages are responsible for the appearance (theming, etc.) of the interface of LibreOffice under Gnome and Unity 7. Removal of GTK packages means that appearance is stripped. Since we apply this workaround, we have appearance issues, as a drawback. By the way: 'libreoffice-gtk3' package is not installed by default. It was mentioned, just in case someone installed it optionally and forgot it. Commented Jun 20, 2016 at 23:24
  • 4
    This issue is still present in LibreOffice 5.1.4.2. Removing packages solves the issue, but makes LibreOffice look ugly. Commented Jul 13, 2016 at 7:47
  • 2
    Issue still present in Version 5.1.4.2 Commented Oct 27, 2016 at 5:46
  • 1
    Issue also still present in 5.2.0.4 Commented Mar 16, 2017 at 13:08
3

In Ubuntu 16.04, to make LibreOffice Impress 5.1.4.2 fast just remove the libreoffice-gtk package. Don't remove the libreoffice-gnome package, which is necessary for the UI to look good and be properly integrated with gnome (e.g. expected integrated open file dialog). So:

$ sudo apt-get remove libreoffice-gtk

Now copy-pasting slides is fast again, and scrolling the slides as well.

2
  • If I only use LibreOffice Calc particularly macros and forms would there be any benefit removing gtk or should I just leave things as is? Commented Sep 9, 2016 at 2:53
  • 2
    This also uninstalled libreoffice-gnome. Commented Oct 5, 2016 at 7:18
2

The problem seems to be caused by bugs related to the GTK3 builds of LibreOffice (look here and here). As fare as I found out, the only way to work around is to switch back to the GTK2 version. At first you have to be sure the related packages are installed:

sudo apt install libreoffice-gtk libreoffice-gtk2

Then you can start LibreOffice with GTK2 temporarily with:

SAL_USE_VCLPLUGIN=gtk SAL_SYNCHRONIZE=1 libreoffice

Now it should work again normally. If it does, you can remove the GTK3 package to force LibreOffice to use the GTK2 version permanently:

sudo apt purge libreoffice-gtk3

Shame on Canonical to deliver an untested version of LibreOffice!

6
  • necro much? ~4 months old
    – negusp
    Commented Oct 13, 2016 at 21:13
  • 2
    @PatrickNegus This problem exists in Ubuntu 16.10 as well, so I think unfortunately it is still a topic.
    – user5950
    Commented Oct 13, 2016 at 22:55
  • yea, unfortunately
    – negusp
    Commented Oct 14, 2016 at 0:38
  • 1
    This fix works for me, LibreOffice with gtk2 package instead of gtk3 is fast and responsive as it used to be before I make a fresh install of Ubuntu 16.10.
    – greguti
    Commented Nov 18, 2016 at 15:08
  • @greguti Then vote for it!
    – user5950
    Commented Nov 19, 2016 at 0:34
0

You can try a newer version of libreoffice to see if that fixes the issue by downloading the .deb:

https://www.libreoffice.org/download/libreoffice-fresh/?type=deb-x86_64&version=5.1&lang=en-US

1
  • It's actually true: I tried the pre-installed version again, and it was a bit faster. But not closely as fast as when I remove the above mentioned packages. Commented Jun 20, 2016 at 20:48
0

Upgrading to Libreoffice-5.2.1 solved the problem for me.

3
  • is this available thorough the official 16.04 LTS repos? Commented Jun 10, 2017 at 19:11
  • 1
    as of today, ubuntu 16.04.05 uses Version: 1:5.1.6~rc2-0ubuntu1~xenial4 Commented Oct 23, 2018 at 4:52
  • But using snap (sudo snap install libreoffice), ubuntu 16.04.5 provides Version: 6.1.2.1 canonical Commented Oct 23, 2018 at 5:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .